Working fine a min ago, tons of interference when recording


I just downloaded the latest version of Audacity. I am running it on a Windows 7 Sony Vaio Laptop. I installed the software, plugged in my usb mic, and opened audacity. After playing around with the settings, I set the Audio Host to Windows Wasapi, and choose usb audio device for the Recording. I did this by going to edt >>> preferences. This was the only combination of settings that worked, but it did work. I tested the audio, and played it back. It was crisp and clean of static or background noise.

Then I messed things up.

I then closed the test audio and imported a mp3 track that I wanted to edit. I successfully edited the track, saved it, and then went back to record a new audio track, but nothing happened. I deleted audacity from my computer and re-installed it hoping this would fix it, but it did not. Still no sound or recording ability using the Wasapi Audio host. I then switched to MME and the audio registered and recorded, but came out with a ton of static and background noise. But at least it recorded which I could not get it to do with the previous settings.

One thing to note is I unplugged the usb microphone and the laptop speakers are still active. And when I record using the computer speakers, (still using the usb audio device for the Recording) it sounds fine without any static and background noise.

Thank you for any and all input.



I deleted audacity from my computer and re-installed it

During the Windows install, there should have been a check box to reset Audacity Preferences. If you don’t check that box, the new Audacity will install and open exactly where the old one left off. Normally, that’s a good thing because it lets you upgrade Audacity without putting all your settings in again. It’s less valuable when you want all your settings to go away.

The recording you made with the interference was probably coming from the laptop built-in microphone rather than the USB. Those are the only two microphones in the system.

Audacity will not see a USB microphone if you plug it in or change the connection after Audacity starts. Plug the microphone in and restart Audacity. See if your microphone connection comes back to life.


A note. Windows has built-in “Enhanced Services” that try to cancel room noise. It’s designed for voice conferencing but it will kill a musical performance.


What are the exact three numbers from Help > About Audacity? See the pink panel at the top of the page.

Unless you are using 2.0.6-alpha (which you shouldn’t unless you know what you are doing because it is an unreleased test version), then Windows WASAPI can only record computer playback from an output device. It has no option to record from a USB mic or any other input device.

If it was recording your USB microphone then it was doing it because you had set Windows to play the USB mic through a playback device.

As Koz, says MME host should work OK if you select the USB mic as Recording (Input) device. Choose 44100 Hz project rate bottom left of Audacity, until you know higher rates will record properly. If higher rates record properly and you have a reason to use them, choose Windows DirectSound host instead.

If you have not already seen it, have a look at Missing features - Audacity Support .