Won't record.

Windows 10, Audacity 2.2.1
Hi I’ve had Audacity for about a month and have been using it successfully. Now all of a sudden I tried to make a new file. I clicked “record” and this error message came up:
“-Error opening sound device. Try changing the audio host, recording device and the project sample rate.”
I changed the audio host from MME to Windows WASAPI and the error message stopped coming up.
However now I cannot record. The blue images of sound waves are missing from the grey bars whenever I click new file. And yet existing audacity files work fine. Yes, they have the blue images of sound waves. It just won’t happen when I try to make new ones.
When I try to make a new file and press the record button the red triangular button does move and the file does save. But there is no sound when I record a new file or when I play it back.
I have tried going to “Preferences” then “Recording” and checked “Software Playthrough.” I have also unchecked “Other tracks while recording (overdub).” Still no luck.