Won't read or write to external harddrive (D:)

Background: I record a podcast using Audacity and our sessions run about 1.5-2 hours long. I then save the file for later editing. I use a Seagate External Hard-drive (D:)

I recently downloaded the Audacity 3.0.0 and since then it will not save data in the files or will not read them correctly. I can open a previous AUP file from the external hd, and I can save that same file under an alternative name, such as name_edit1, however, when I close the program and go to open that new file, it tells me that it cannot read the file in D:.

Also, when I edit the original file, and attempt to save it or back it up, it tells me that D: is not write-able or is full. It is not full. It is a brand new 2TB hd. So i have been stubbornly doing all of my edits, and then exporting it as an MP3 in order to save the audio file.

What am I doing wrong. Is the hard -drive not formatted correctly? Is there a bug in 3.0.0? Help please.

If the drive is formatted as FAT32 you can’t save Audacity 3.0.0 projects.

how to find out if a drive is fat32

The drive says exFAT?

exFAT should be OK.
How is the drive connected to the computer?

the hard drive is connected via a usb cable.

Where does it say that?

Have you checked in “Disk Management”? (see: https://kb.netgear.com/29640/How-to-identify-your-hard-drive-format)

when I follow your directions, after opening disk management, it is listed next to the drive that the file system is exFAT. when you right click the drive and go to properties/volumes, it says that the partition style is MBR. Does that help in any way?

Are you able to create a new file on disk D:
(for example, create a new .txt file)

A couple of things:

  1. Will Audacity 3.0.0 work with data on your C: drive?
  2. Where did you get your Audacity from?
  3. I just saw another post (by steve) that suggested the following:

There’s an article here about setting the privileges for an app. > https://www.howtogeek.com/368598/how-to-manage-app-permissions-on-windows-10/
Audacity must have (at least) permission to access the microphone, and permission to access Documents.

I can save .txt files to the harddrive with no problem.

To answer the other questions, yes i could run .aup files from C:\ but i don’t have the room on that drive to maintain so many files, and i got the download from the audacity website, not a third-party site.

When i attempt to open the app permissions, it does not give any options other than to uninstall.

To check the hard drive permissions:

  1. Open “ThisPC”

  2. Right click on the external hdd and select “Properties”

  3. Click on the “sharing” tab.
    Does it say that the drive is shared?

  4. If the drive is shared, click the “Advanced sharing” button.

  5. In the “Advanced sharing” window, click the “permissions” button.

  6. Take a screenshot of the permissions window.

The drive is not shared.

I saw that they released 3.0.2
Should I download that and see if i have better luck?

You can certainly try it, though I’m not aware of any recent changes in Audacity that relate to this.

the hard drive is connected via a usb cable.

How long is the USB cable? These are some of the same symptoms that Audacity exhibits when it tries to manage cloud drives with notoriously sloppy access.

What was the drive before this one?

Is it spinning metal and not Solid State? Does it try to “go to sleep” periodically during operation? That can cause access problems.

The advice for Cloud Drives is do all the work on an internal drive and do all the transfers on and off the “drive” outside of Audacity. Only use the services for archive and long storage, not second-by-second editing.

Avoid doing production in MP3. MP3 creates sound damage and it gets worse as you edit. You can’t stop it.

i could run .aup files from C:\ but i don’t have the room on that drive to maintain so many files

If you can’t edit an hour show on your internal drive, you may have just posted the real problem.


The usb cable is about 6 -8 inches long.

(https://www.staples.com/seagate-2tb-backup-plus-slim-portable-usb-3-0-external-hard-drive-black-sthn2000400/product_24383778?cid=PS:GS:SBD:NB:TransTech&gclid=Cj0KCQjw9_mDBhCGARIsAN3PaFOae8pxxBThjYepvn_fG_olNvOKBgbNdsgoC1naj_6EyCYbD-_ON64aAl7yEALw_wcB ) is what I have.

Before the Seagate External HDD (D:) I was using a flash drive. I do not know if it is solid state or not. I also do not know if it “sleeps”.

As for my C:\ drive, i run a photography business and most of my internal harddrive is photos.

The drive specifications have the RPM as “Other” and it’s powered from the USB cable, so it’s probably an SSD and that’s not it.

I think it’s the Party Line that you upgrade to 3.0.2. It fixed a lot of problems in 3.0.0. If that still doesn’t work, it’s possible go back to 2.4.2 from the posted archives if you didn’t keep the installer.



most of my internal harddrive is photos.

Are you following digital hygiene? Be able to point to two separate places that have your valuable work? Internal Drive, External Drive, Cloud Backup and Flash Drives all count as one. Two folders on your internal drive doesn’t count. I recently rescued some valuable work from a large Windows machine because I had copied the work to a second internal hard drive. The main hard drive went into the dirt, but I got the work from the second drive.

Oddly, three or more doesn’t count, either. Nobody keeps three drives current.


the photos on C:\ are backed up to a different external than the one I am currently trying to use for the podcast. I haven’t tried moving my podcast files to the photo external hdd to see if it has the same problem.

but I did re-download 2.4.2 to work with my original files for now.

the photos on C:\ are backed up to a different external than the one I am currently trying to use for the podcast.

Are you going through a USB hub or other multi-point USB management system? Those have caused live production problems for years.