Won't play from my soundcard...

Win 7 Ultimate - sp1
i5 Quad core - firmware and bios up to date
RME Fireface 400 soundcard - all drivers and firmware up to date
SSD drives
New computer as of Oct-12

I have been using Audacity for several years now.

Yesterday, I installed 2.0.2 and assigned my soundcard to Audacity. I brought in a file (32bit float - 96k) and pressed the space and/or the play button on the transport bar. The play button appears to have been pressed. Nothing moves. The cursor won’t move and, of course, no sound. The cursor line also becomes invisible. I press stop and the play button pops up and the cursor line reappears.

So I assigned my internal soundcard and opened a 44.1k file (that’s as high as it will go; maybe 48k) and it played. This is obviously no use to me since all my files are in 96k. I have been using Audacity primarily for denoising tracks. This is the best denoiser I’ve used; ease of use and great parameter shaping.

Now here’s something interesting. Yesterday, I decided to uninstall version 2.0.2 and replace it with version 2.0.1…and it worked perfectly. I pressed play and it worked without a hitch. So I get up this morning, ready to dive into my work and this older version now doesn’t work; just like yesterday before I changed versions. So I’ll be changing back to the newer version.

Can anyone solve this mystery? Is there a setting that I missed?

Any help would be greatly appreciated.

What settings do you have in “Edit > Preferences > Quality”?

Hi Steve, Thanks for the quick response. Here’s where I am presently.
I replaced the older version with the newest version. I rebooted (just in case). I brought in a 96k file and it worked. Then I opened a 44.1k file and it didn’t work. I brought back the 96k file and it didn’t work this time. I rebooted again, now both work. ???
I am curious about this quality setting though. It could be the problem. Here’s what I have:

Default sample rate: 44100
Default Sample Format: 16 bit

(Real-time Conversion)
Sample Rate Converter: Fast Sinc Interpolation
Dither: None

(High-quality Conversion)
Sample Rate Converter: High-quality Sinc Interpolation
Dither: Shaped

I’m not sure what this means, so I never touched it.
Any changes?
Thanks again.

Those are fine (recommended settings) - leave them like that.

There is some sort of “communication” problem between Audacity and the sound card, but from the information so far I see no obvious reason.
I’d suggest that you continue using it and see if any sort of pattern emerges as to when it works and when it doesn’t.
Is it working OK now?