Wonky all of a sudden

I am using Windows 7 Ultimate, 64bit. I currently have Audacity 2.0.5 loaded, via audacity-win-2.0.5.exe. I have Lame-v3.99.3_for_Windows.exe.

Hello. I have been using Audacity in various versions for about six years, quite successfully, to record audio and perform minor edits, with no issue. I recently sat down with my client to record some audiobook chapters with a new external USB microphone (a Blue snowball). I had done a brief test with it on a previous version of Audacity and it sounded great. So, my client was here and I always check to make sure things are sounding okay and discovered after my first recording, that it was playing back distorted. It sounded warped, sped up, slowed down, there were artifacts, crackles, etc. My client was here waiting to work, so I checked my version of Audacity and realized there was a new one. I uninstalled old version. Deleted the old exe file. Downloaded and installed 2.0.5. The problem continued. :astonished:

I ended up plugging the mic into my iPad and using a recording app to create a bunch of wav files. They sounded fine, clear, in that app. After the recording session, I copied the files off the ipad and tried to play them in Audacity. They sounded distorted. Ended up converting the wavs to mp3s in iTunes. I tried to play the converted mp3s in Audacity also. Same distorted playback (although they sound fine in iTunes and Windows Media Player). Unfortunately, I still need to edit these mp3s. I really want to use Audacity to do this - I need to use it because there are no comparable, reliable tools out there to do it. I hope that someone can help me, please. I truly appreciate any suggestions you might have for me.


Was the Blue snowball the only new thing in your setup? Was it plugged into the same hardware? Was it plugged into the same Windows system?

The mic was new, but as I said, I tested it with Audacity when I bought it and it seemed to be working fine. Plugged into same hardware. Same Windows system. I am not aware of any changes in software either.

Did you make sure that all Windows Enhanced Services and Playback Special Effects were turned off? See http://manual.audacityteam.org/o/man/faq_recording_troubleshooting.html#enhancements

You also might need to turn off any sound effect in the sound card own control panel.

Finally, here is from the Snowball FAQ:

  • Is the Snowball connected to a USB port? Hubs will not provide the appropriate current to power the Snowball.

  • Is the Snowball selected as the default input device in both the System and Software Preferences? Also, make certain you have an adequate amount of volume set.

  • The Snowball’s digital output is set to 44.1kHz / 16-bit. This is not user-definable.

Have you got the same settings in Audacity?

If the files recorded on iPad sound OK in Windows Media Player then presumably the “only” problem is with playback in Audacity.

What playback device have you chosen in Device Toolbar ? Is that device the default playback device in Windows, which is what Windows Media Player will be using? To check, right-click over the speaker icon by the system clock, then choose “Playback Devices”.

You could also try reinstalling 2.0.5 with “Reset Preferences” checked which should make Audacity use default settings, and should make it select the Windows default playback device.


Ah! Gale! You may be onto something! I started noodling in the Device Toolbar.

By changing the Audio Host to Windows WASAP (I am using Wndows 7) and the Speakers to my default (Dell USB Audio speakers), the clips now playback correctly! The bad news is that I can’t record audio with those settings. Literally. Nothing happens when I press record. Okey dokey.

The only way to record is using the MME setting. Not sure why this is. As I said, I have used Audacity hundreds of times in the past, albeit with one of those crappy 4 dollar clip mics plugged into my microphone port, and had zero trouble operating perfectly on the default settings. That’s what I get for trying to go all “uptown” I guess. I am looking forward to exploring the settings and capabilities more deeply when I am no longer working on the time deadlines of a deliverable project. I remain a fan of Audacity and its great capabilities and am very grateful for this forum as a place to seek answers and become a better user.

P.S. Thank you for your response, Robert2. Luckily, it was not a microphone problem after all. I love my snowball. It has a cool glowy red light and everything.

Currently, the only input devices available for Windows WASAPI are “loopback” devices for the playback devices you see in Device Toolbar. You can use one of those inputs to record playback from Device Toolbar’s currently selected playback device.

So with the “Dell USB Audio Speakers” selected as playback device and the “Dell USB Audio speakers (loopback)” selected as input device, you could record audio that was playing through the Dell speakers.

You should also be able to record using the “Windows DirectSound” host.

It’s fine to record with MME too, but that host resamples all audio to 44100 Hz. That may not cause any audible problems but if it ever does so, you should set the Audacity Project Rate bottom left to 44100 Hz and you should set the Default Format for the Snowball in Windows to 44100 Hz. You would do that by right-clicking over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the Snowball then choose “Properties”. Then click the “Advanced” tab.

Similarly you should be able to set playback in Audacity to the Dell USB speakers and choose MME or Windows DirectSound.

If you regularly change the device you use for Windows default playback device, you can instead choose “Microsoft Sound Mapper - Output” as Audacity playback device if you use MME (or “Primary Sound Driver” if you use Windows DirectSound). Those choices automatically select whatever is the Windows default playback device at the time.


I’ve experianced similar issues where old Audacity files I ahve waiting to edit and export play all funky when playing them back. Even before downloading the new version here. No other changes took place, same equiptment and everything. Even new recording with the 2. version are sounding weird. Starts out playing normal but goes wavy echoing etc…Going to look at the things mentioned in this thread and see what happens.

What you are describing sounds like Windows sound enhancements ( Audacity Manual ) or sound device driver issues ( Missing features - Audacity Support ).

If you have questions about this, please start a new topic. Give specifics of your setup (version of Windows, make and model numbers of the computer, of the sound device and of the physical recording equipment). Say what you are recording.