Windows10 update, noise reduction no longer works [SOLVED]

My windows10 computer self-updated itself last night.
I’ve been trying to edit a wav file using noise reduction. It no longer works. (It worked fine a few days ago, before the latest windows10 update) This is what happens:

Part 1- choosing the silent bit and clicking Effect → Noise reduction → Get noise profile works fine.

Part 2- I then select the whole wav file and click on Effect → repeat noise reduction

Nothing happens. Normally I’d see a progress bar displayed. Now nothing happens. I’ve tested different wav + mp3 files. Same thing.

So, I resorted to an older version of audacity, which worked fine when I bumped into the “device not found” issue some months ago. Same problem, it didn’t work.

What is your version and build of Windows 10? To check, press the Windows key, type “winver” (without quotes) then press ENTER.

What version numbers of Audacity are you using and where did you obtain them from?

You should be using Audacity 2.1.2 from unless you can’t solve Internal PortAudio Error by updating your audio drivers, in which cases your choice is Audacity 2.0.3 or 2.1.3-alpha.

I don’t see your problem on Windows 10 Version 1511 (OS Build 10586.420) in 2.1.3-alpha. But if your selection is only a few seconds, you won’t see any progress dialogue when you repeat Noise Reduction. If you look at View > History…, does it say Noise Reduction has been applied?


My goodness, entirely my fault! :open_mouth: (and yes, I was using latest version of both W10 + Audacity)
The voice file was less than 1 minute, and that’s what was happening, I was used to working with my longer files!

Thank you very much Gale, much appreciated! :exclamation:

Topic can be closed.