windows wasapi stops record when silenced.

how can i make windows wasapi just record without stopping?

WASAPI loopback allows Audacity to record directly from a output stream. When there is no output stream, there is nothing to record so WASAPI loopback recording will stop. The only way to keep it recording is to keep the output stream active.
Why do you want to record silence?
If you want a period of silence within a recording, you can generate it later using “Generate menu > Silence”.

i want to record audio for a gaming youtube video, when there is silence i need there to be silence.
there is no way to just capture sound without any effects?

Does your computer have an option to record from “stereo mix”? If it does, that might work - you would need to select it in the device toolbar (if it is an available option, which depends on your sound card drivers).

i having problem with the stereo mix, its not apears im trying for long time to fix it but no solution.
i must find a way to capture my voice and computer voice with out problems and effects like it does now.

Moved to the correct Windows board.

Have you tried enabling stereo mix in Windows Sound? See Missing features - Audacity Support.

WASAPI may well record silence once you have started and stopped a recording - it depends, but very often the audio player once started will leave its “endpoint” open even when stopped. So try recording a few seconds with a stream playing before starting the real recording.

Gale

To have a consistent time code over the length of the recording when I sync it with other recordings.

Scenario: I am recording a video of my desktop for a tutorial. At the same time I want to record the audio with Audacity. Assume it’s a basic tutorial about how to use the Youtube player. In this case Audacity would only record audio when you have a Youtube video running (Additional info: With the HTML5 player it pauses immediately, with Flash it keeps going for 10s and then stops). The audio recording would be useless for this case because you can’t tell where Audacity stopped and how to sync the parts to the video.
I’d rather record silence than losing the relative time of the recording between sound events. If I don’t want the silence, I could always use the truncate silence effect.

There are ways to mitigate this issue though.
If the program that is recording my microphone is currently recording, Audacity won’t pause its recording even when there is silence (Interestingly, the mic recording is not monitored.)
The same happened in a test when a game is running. It was a proper 3D game, not a browser game. Even though there was no sound coming from the game, Audacity kept recording.

The problem is that it is hard to rely on these workarounds. If a game reinitializes the sound, Audacity might pause. Other games might not prevent Audacity from stopping during silence.

So, yeah, even though it is only silence, information is lost by not recording it. And I’d rather have an option to keep the silence in the recording than losing this crucial information. Stereo mix isn’t really a good option. While this doesn’t happen with that source, there is some tiny noise in the audio. Wasapi is super clean.

PS: I have only tested this on a fresh installation of Win 8.1. This wasn’t done because of recording issues and is completely unrelated. But I though this behavior wasn’t in my previous installation. But it’s impossible to check now if that is the case, obviously.
Until now I have used Audacity only for mic recording, where this isn’t an issue. But my current desktop/game video recording software has very bad audio quality.

@Mugros, we could possibly add the ability to pad with silence when no audio is coming into the WASAPI stream. A few people have asked for this. That might mean that if someone wanted the current behaviour, they’d have to enable Transport > Sound Activated Recording, or it might mean the pad would have to be an option itself.


Gale

That is a good idea and IMHO it would also be a more logical behaviour.
When I encountered this behaviour it didn’t make any sense for me. I checked for an option that makes Audacity stop the recording automatically, but couldn’t find any. Online I found info on Sound Activated Recording, but that was off.

It also just came to my mind that I tried to record in the past and noticed that cursor won’t start running and is just blinking at the start. I always thought, that this is a bug or failed initialization and that it wouldn’t record anything at all, since I expect the recording to start regardless if there are any sounds played.It never occurred to me that this is due to Audacity waiting for an audio source playing sound.

I imagine that many will.
I expect that many users will find it to be very convenient that they can set Audacity to record another application and that Audacity starts the recording as the other application starts playing, and then Audacity stops recording when the other application stops playing.

I had the same problem and found a workaround for this problem. Open some audio clip of a duration of 30min or 1 hour in Audacity and select all and Generate Silence. Then save the audio clip as a mp3 file with some name (such as Silent Audio). Then open the file and play it on repeat mode (VLC recommended) in the background. Now the Audacity WASAPI recording won’t stop as long as this file is being played in the background. There is no audio interference whatsoever.