Windows WASAPI and Audacity - impossible to record what sounds on the computer

Hello everybody,
I’ve been using Audacity for years and recording material that sounds on the computer but a few days ago this option stopped working. All the configuration parameters (WASAPI and al.) are as before the malfunction.
I set Audacity in the record mode by clicking on the button, then start playing the audio file I want to record and nothing happens. There is no progression in the recording spectrum.
I don’t get an error message either. There does not seem to be any communication between the sound system on my PC and Audacity. I have tried with previous versions of the program but I have been unable to solve this problem.
Apparently WASAPI and Audacity don’t seem to work together well because I cannot reproduce any audio material through WASAPI either. I can reproduce (but not record) through MME and Windows Direct Sound. Up until a few days ago there was no problem.
I have another computer on which Audacity works perfectly and I can work with all the functions I need. Unfortunately on my desktop I cannot make a recording of what sounds on it now.
I wonder if you would be so kind as to give me information about how to solve it.
Thank you very much in advance for your attention.

You have to select WASAPI and then for the Recording Device with the “loopback” option for the device the sound is coming out-of (usually your soundcard).

“Loopback” won’t start recording if there is no audio stream, so you may have to start playback first. (A silent stream is OK, but no stream is not OK.)

Hi DVDdoug,
Thank you very much for your help and your prompt reply. I have always used Audacity with the same settings, selecting WASAPI and with the recording device in the loopback option.
I wonder why Audacity does not work now to make recordings. It doesn’t record (there is no sound spectrum even though there is audio streaming coming from the computer) and although it reproduces audio files I cannot listen to them through WASAPI (I can listen to them through MME or Windows Direct Sound).
The reason why I started this thread on this forum is that I don’t understand why this error has happened suddenly. I have never changed the settings on my desktop. I have also uninstalled Audacity several times and re-installed it using older versions to see if the problem can be solved but the problem still remains.
Thank you very much in advance.
Kind regards.

This topic was automatically closed after 30 days. New replies are no longer allowed.