Windows 64 bit

I am now using Audacity version 2.0.3 downloaded as an exe file, with Windows 8 64 bit and I am currently experiencing 2 problems. Both of these problems also occurred when I temporarily used version 2.0.2 with Windows 7 64 bit. For many years previously I had used versions 2.0.2, 1.3.x and 1.2.x under Windows XP 32 bit and did not experience either problem.

  1. When I record directly from, say, a track already on my computer, the recorded version is much more trebly than the original. This is quite noticeable on the first recording and if I record the recording of a recording etc., the result becomes unusable.
  2. The input volume level is now linked to the speaker volume level. As such I cannot separately turn down the speaker volume whilst recording. Fortunately, I can mute the speakers and this still leaves the previous volume level being recorded but I often wish to have the sound audible in background so that I can monitor what is happening. With version 2.0.2 under Windows XP 32 bit I could adjust the input sound level to Audacity totally independently from the speaker volume.

Does anyone have any suggestions as to overcome either of these problems?

  1. When I record directly from, say, a track already on my computer, the recorded version is much more trebly than the original. This is quite noticeable on the first recording and if I record the recording of a recording etc., the result becomes unusable.

Since a “pure” digital recording doesn’t do that, you’re not performing a pure recording. You can get distortions like that if you’re really recording your speakers and microphone instead if an internal pathway.

Win7 and Win8 both default to conferencing voices and not recording entertainment media. There are special settings for that you can turn off – if you can find them.

  1. The input volume level is now linked to the speaker volume level.

You might be stuck with that. Self Recording is not a guaranteed service like lighting up the screen or making the mouse go back and forth. Some newer computers can’t do it at all now. The fact that yours works means you win. Self Recording can be performed a number of different ways and since it’s a juggling act between the OS, the Drivers and the Sound Card, that may be how yours works now.


Your complaints are to do with not being used to Windows 7, and not to do with Audacity.

See for more.

Koz answered you about Windows 7 sound “enhancements”.

There is no “silent” recording of computer playback on Windows Vista and later because there is now no “Speaker” or “Master” system volume slider independent of the “wave” output slider. The Master output slider is the one you could turn down on XP without affecting the “Wave” output slider, but even on XP the Wave slider did affect recording of computer playback.


Thanks very much for your responses although I certainly hadn’t intended my questions and comments to be regarded as complaints.
I do realise that there is a difference between recording using the microphone and speakers and recording directly. I had, of course, disabled the microphone in Recording in Sound from the control panel and, I had disabled the SPDIF Interface in the Playback devices in Sound. Therefore I had the Stereo Mix enabled and set as default for recording and the Speakers enabled and set as default for playback. I had previously read the notes in the 2 links that you show but I went through these again thoroughly ensuring that the settings I was using were correct and testing a few alternatives. I have now sorted out the problem.
The problem, and I only mention it here in case it assists anyone else, turned out to be that even when I checked the box to “Disable all enhancements” on the speakers, this didn’t always happen. I cannot yet establish in what circumstances it does and doesn’t work but I have found the safest way to be to enable enhancements then turn off each enhancement individually and then check the box to turn off all enhancements. This then works all of the time. Of course, it makes the input sound rather tinny but the recorded sound is then identical to the input and will sound good again when either the speaker enhancements are turned back on or if the result is burned to a CD.
I totally accept your comments that the restrictions on separating the volume adjustments are a function of the Operating System. This is a pity but I would appear to be fortunate in that I can still record when the speakers are muted.

So the enhancements are not disabled in practice if you check “Disable all enhancements” when the individual enhancements are checked (and the “disable all” leaves the checked enhancements greyed out)? I see that greying out on my Windows 7 netbook, but all enhancements do seem disabled then.

Or does checking “Disable all enhancements” uncheck the individual enhancements but doesn’t audibly disable them?

One thing you could try is doing the disabling in the sound card’s own control panel, if it has one. Or see if you have correct 64-bit sound device drivers made by the computer or motherboard manufacturer. See here .


I’ve spent a long time on this today to try to determine exactly what actually is happening. I therefore opened Audacity and imported an audio track. I played it and it played, as I would have expected, with the enhancement (there has only ever been one checked apart from when I was testing before I posted originally) turned on. I then checked the box to turn all enhancements off. The individual enhancement box was still showing as checked although it could not be accessed. It was not greyed out but the surrounding panel for all enhancements was greyed. I played the track and the enhancement had not been turned off. I unchecked and rechecked the box to turn all enhancements off but it made no difference. The enhancement was still on. I therefore turned off the individual enhancement and this worked. Turning it on and off continued to work as I would then expect. However, from that point on, checking the turn all enhancements off box then worked, whether the individual enhancement was checked as on or not. Also, from that point on, I have been unable to recreate the initial problem. I have tried all combinations of the settings, deleting and reimporting the track into Audacity, deleting and restarting Audacity and even restarting my machine, both from cold and from sleep. At no time now can I recreate the initial problem.
Before I posted originally, I ensured that my sound card drivers were up to date and that the drivers were from the manufacturer. This therefore certainly appears to be a peculiarity of my machine so I really should not waste any more of anybody’s time here. If, in the future, I am able to establish under what circumstances the enhancements are not turned off by the disable all button, I’ll post again.
In the meantime, thanks for all your help.

Yes indeed, but you should be able to defeat that by inserting a blank mini-jack stereo plug ( lead, no headphones) into the headphone socket of the PC


This wasn’t mentioned on the Windows 7 Wiki page so I added it.


Good addition - it’s an inelegant kludge - but it works :nerd: