Windows 10!!!

At the risk of repeating other posts, I’ve had problems using Audacity (first problems ever) since “upgrading” to Windows 10. My PC is a Dell Inspiron 570 and Dell doesn’t support Windows 10, yet. I upgraded from the basic, reliable Audacity 1.2.6 to 2.1.1 to see if that made a difference. It didn’t. I was still getting the error message “Error initializing audio. Could not find any audio devices. You will not be able to play or record audio. Error: internal portaudio error,” the same as a lot of other users. I followed your suggestion of updating drivers, updated Realtek and now no longer get the error message! Success! I can play old audacity files or new imported audio files.

I haven’t tried recording via a stereo input, yet, but I have tried recording directly from an audio signal on the PC itself (internet broadcast). This normally works fine but doesn’t any longer. Do you have any more suggestions? What should my Audio Host and Recording Device settings be?

It is normal to have to upgrade to newer manufacturer’s audio drivers when you upgrade to a new operating system. Where possible, these should be drivers for your specific computer model from the web site of your computer or motherboard manufacturer.

If you obtained drivers from the Realtek site, they are not matched to your motherboard, only to a generic Realtek specification. This could cause problems for more advanced functions.

I suggest you try Windows WASAPI host and the “(loopback)” recording choice:

If you need more help please say exactly what happens when you try to record computer playback (“doesn’t work” doesn’t really help us diagnose).


I’ve been having this problem myself. Used a behringer USB mixer to record. Windows 10 detects it and activity on it (talking into mics etc) but when I load audacity it detects no audio devices on my PC when it’s plugged in. If I unplug it, audacity suddenly can see the built in devices on my laptop

Thank you for that information.

Can you give the model number of the Behringer mixer? Have you installed Behringer drivers for it or is it using Windows’ USB drivers?


We definitely have a pattern here - I’ve been looking at this all day. Plug in an ASIO USB soundcard and Audacity does not “see” any MME, WASAPI or DirectSound drivers/devices. Unplug and Audacity comes up.

Windows 10 upgrade (build 10240)
Audacity 2.1.1
Line 6 Toneport UX1 - driver
Realtek High Def Audio on board - driver (was disabled until today)
My audio cable setup now is the MME on board device feeding into the monitor in on the Toneport (a typical setup)

This also happens for Cycling 74 Max 6 & 7
Max 4 Live in Ableton Live can open devices but can’t edit
I believe that MSP (associated with Max) can only run under MME as well, so there appears to be a link.

Ableton Live 9.2 cannot see MME until USB is unplugged
Reason 7.1.1 & FL Studio 11.1.1 can see everything all the time

BTW the Toneport cannot be controlled by the Windows Audio tray icon (Control Panel applet). You can only change volume with the hardware knob on it.

I’ve tried

  • writing to Cycling - they said the audio driver loads right before the Max program crashes
  • Using just the TonePort (my on board Realtek card has been disabled pre-Win 10 - I only enabled it in BIOS when I saw other users were having these types of results)
  • with Max 6, I uninstalled both 64 and 32 bit versions and then reinstalled 32…then reached for Max 6, 32 bit - only works if Toneport is unplugged
  • 41 and 48K for both devices
  • swapping default device
  • toggling the exclusive device checkboxes on both soundcards
  • reinstalling all the Line 6 software - suspiciously, their Win10 driver has a date of 2013 on it!

I have Behringer and M-Audio USB devices I can try, but not tonight…the fact that the above poster was using Behringer makes me wonder if any of it will work.

By “ASIO USB soundcard” do you mean just Toneport at the moment?

Yes - some of the problem comes from Line 6.

So does Audacity 2.0.2 or 2.0.3 see the built-in devices with Toneport connected?


Yes by “ASIO USB soundcard” I only mean the Toneport.

I’m using Audacity 2.1.1 here…blank Device Toolbar dropdowns…I can run through an install of an older version later.

Update - it works in Audacity 2.0.3

Looks like no one has an answer for this.

As you say, use Audacity 2.0.3.

Or press Line 6 to actually provide a new driver for Windows 10.


I’ve since moved on to a Focusrite Scarlett Solo - no stereo inputs but I will either use something else or upgrade that if I really feel the need. For now, the UX1 goes back into the drawer…the same drawer I picked it up out of and said “hmmm, why is THIS here???.” Now I know.

Hi and i was able to get Audacity 2.x to work on my newly upgraded Win 10 system. Just my experience you may have different luck.

Background: I was running Audacity 1.x version on Win 7 with great results. Upgrade to Win 10 left me with ability to play but not record. Upgrade to Audacity 2.1.x installed fine but then i got the too-common: “Error while opening sound device. Please check recording device settings and project sample rate” message. To make a long story shorter:

a) I went to Realtek web site and got their latest driver: Installed same. This change eliminated the startup error message and file playback returned as normal, still no record capability.

b) To fix record, right-click on the speakers icon in system tray; select Recording Devices. Note that I had two sources that were disabled (!!). Select (left click) Stereo Mix, enable it, set it as Default Device. This change restored ability to record, but I was getting an echo. So step c):
c) Go to Audacity menu/ Transport. Unchecked Overdub and Software Play Thru.

That did it for me - all good again. And again, your system may well be different but hopefully the principles are the similar.

Thanks - that looks like essentially the steps I took. I am doing just fine with the Focusrite now and the UX1 offline.

Thanks for relating your experience.

Those Realtek drivers are a solution for some users, but as Realtek say, they are generic drivers not matched to your sound card. If the computer or motherboard manufacturer actually have Windows 10 drivers for your computer listed on their site, those drivers will be properly matched to your hardware and (in principle) would be preferable.