[Windows 10] WASAPI only works when line in is 44100

Hi all,

I am on Windows 10 using Audacity 2.1.2.

I am using Audacity to listen to my USB turntable. I have the turn table set as a recording device and my output it through a Focusrite Scarlett 2i2.

Scarlett is set to 2 channel, 16 bit, 96000 Hz in Windows. That is the highest it goes.
Line in from USB turn table is set to 2 channel, 16 bit, 48000hz

If I try to use WASAPI in Audacity when monitoring the turn table, no sound comes through. If I change the line in from the turntable to 44100, then it works.

Why does this happen? Is there a way to have it work without changing the line in settings to 44100?


In general it’s a terrific idea to have all the sample rates match.

Scarlett is set to 2 channel, 16 bit, 96000 Hz in Windows.

In Windows, or in the Scarlett Driver? Isn’t there something about basic Windows services won’t go over 44100?


In Windows, I couldn’t find any software to accompany the Scarlett, just a Windows driver.

I don’t know if there is something with Windows services not going over 44100? I am interested to know.

Also, if I set Audacity to use direct sound, then it works even with all the frequencies sent higher than 44100.

I have that set in Windows. Right clicked on Scarlet 2i2 in the list of playback devices and went to Advanced. Did the same for the turn table as an input device.

It works with everything set to above 44100 when I use direct sound.

I use direct sound.

I think the Party Line is to use the one that works.
Windows 10 was not an upgrade. Windows 10 is a new Operating System and it killed off many drivers, programs and devices.


No. It is widely documented that Windows MME host resamples everything to 44100 Hz, and though that might have been true once, it now seems not so.


The Audacity WASAPI implementation is still fairly experimental - see this section of the 2.1.2 Release Notes: http://wiki.audacityteam.org/wiki/Release_Notes_2.1.2#wasapi. You’ll see that there are several cases where 44100 Hz works better.

What project rate are you setting in Audacity (bottom left)? If the USB turntable recording device is set in Windows to 48000 Hz there isn’t really any point setting Scarlett to 96000 Hz. Upsampling to a higher rate does not make the sound better. It could make it worse. Perhaps try 48000 Hz Audacity Project Rate and Scarlett at 48000 Hz for both recording and playback. Uncheck the Exclusive Mode boxes underneath where you set the Windows sample rate in three places, Scarlett recording, Scarlett playback and USB turntable recording.

If you must set Scarlett to 96000 Hz, try 96000 Hz project rate in Audacity.

If the Exclusive Mode boxes are already unchecked, you could try adding checkmarks. In theory, the checkmark for Scarlett recording should mean that the Windows sample rate setting is ignored by Audacity and it will request the stream at whatever the Audacity project rate is.

You shouldn’t need to use Audacity to listen to the records. In the Windows recording properties for the USB turntable, to left of the Advanced tab where you set the sample rate, is there a “Listen” tab? If so use that feature to play the turntable to Scarlett, if that is the playback device you wish to use.