Windows 10 upgraded from windows 7

Windows 10
Audacity 2.1.1

Using audacity for at least 5 years.

After uppgrading to windows 10 and to the latest Audacity version, audacity was not behaving as usual. Couldn’t save alterations to old projects and some other problems. Specifically using the editor tool pencil when smothing out click-distortion due to electrical failure in the recording equipment. When moving one point a whole segemnt of points were moved to nil and sound disappeared completely!

Solution: As i updated to windows 10 there was a whole lot of programs that wouldnt work. Browswers like Chrome, opera and even the old explorer wouldnt start. Even my bokkeeping program wouldnt work, and i couldn’t access any of my Outlook mails or whatever since acces to the PST-file was denied!
The solution was then to go to the UAC (userAccountControl) and lever the control down to zero! Then it worked! Of course this was a bad solution so after many contacts with microsoft and a lot of cleaning and programerror tools running all my programs were working. But Audacity had theese anoying items as described above. The solution is to run the programs like audacity as an Administrator. Then everything works!
The explanation is that all crucial files and systemfunctions are blocked for security reasons in the upgraded windows 10 for unknown users. Even if you use your old logins they are considered to be new in the upgrade version of windows10 and therefor denying acces to old files.
Most likely you will not have these problems if you are using a new computer delivered with Windows 10 from the start. So right klick on the app and run as administrator.
Hope that this info could save you from a dealing with a lot of problems.

Thanks, Lars. If you can make that happen reliably, please give us exact steps to reproduce the problem 1, 2, 3… . Or are you saying that was part of the same permissions problem you were experiencing - you could not write to the project or temporary folder?

I don’t believe that is correct if the system is working properly. I have installed and run Audacity on Windows 10 as a standard user with UAC on maximum slider setting for half an hour without issue. I can save projects and export (as long as it is not to Program Files (x86) of course). I can open projects from 2010 that were created on Windows XP by Audacity 1.3 versions. I can open a recent project created on Windows 10 by the administrator.

I did notice in Audacity’s Directories Preferences that the user name in the path to my Audacity temp folder contains a shortened “8.3” file name with a tilde. My user name is “veryverylongusername” but the entry in Directories Preferences is “C:\Users\VERYVE~1\AppData\Local\Temp\audacity_temp”. That tilde has apparently caused problems in a few cases (or there were also unstated permissions problems) but the tilde is not creating problems for me right now. My Audacity temp folder is being correctly written at “C:\Users\veryverylongusername\AppData\Local\Temp”.

This is a “clean” installation of Windows 10 Pro into a new partition, but I don’t think there would be a general issue with an inplace upgrade, or we would have heard about it by now.

What do you mean by an “unknown” user?

It may help users with corrupted systems but I don’t think it is of general applicability. There should be no general need to run Audacity as an administrator, once it is installed.


Has just repeated the error:
Opened Audacity normally - not administrator mode - opened a project that was made in windows 7 before upgrading, zoomed in on a piece to repair. Marked the piece to repair, opened the effect menu, chosed repair command, and the whole screen was blanked out. Zoomed out an made a printscreen which is attached.The same result is achieved by using the pencil-tool.
No further comments :exclamation: .

Uploading the doc didnt work so here is a dropbox link:
Kind regards

Thank you for your interest, Lars, but even if there is an Audacity bug, it cannot be fixed unless we can reproduce it.

As I said, I already spent half an hour testing on Windows 10 using Audacity 2.1.1 installed by a standard user with UAC on maximum, and running as that user. I tested projects created in earlier Windows and projects created by other users. I did test using Draw Tool.

Please attach an image directly rather than embed it in a word processor document. It is best to save it as PNG file. Please see here for how to attach files: I have attached your image for you below so it will be easier to refer to it:
This image appears to show that Audacity cannot write a “block file” of data, so replaces the data with a flat line. Issues where Audacity cannot write a data file are usually operating system errors (for example, permission errors) or drive hardware errors.

Audacity cannot modify less than a block file’s length of audio. Therefore if you are zoomed in to show the individual audio samples, the entire screen of audio you are currently looking at will be flat lined if the block file cannot be written.

If you would like us to help you further with this problem, please attach the log file from Help > Show Log… and your audacity.cfg file from Users<your user name>\AppData\Roaming\Audacity.

If you cannot see that “Audacity” folder, open File Explorer and type the following into the address bar:


If you have quit Audacity after the problem in your image occurred, please try to make the problem happen again, then attach the Log immediately after it happens.



I followed the good advise of another and downgraded to Audacity 2.0.1.
It run fine on Windows ten.

Its seems that Audacity is finicky about the Audio Drivers and the Older version is more forgiving.
I will use this until the next upgrade comes in.

I tried many paths to get it to work, but the downgrade was a winner.