Windows 10 StereoMix detected but not recording - SurfacePro

I read through all the FAQs and posts but didn’t see anything like the problem I’m experiencing.

I have a SurfacePro 3 running Windows 10. I didn’t try recording in Audacity before I upgraded so I don’t know if the problem is Win10 or something else. My Audacity is 2.1.0.

I enabled the RealTek StereoMix as the default recording device and muted all other mic inputs. I’m trying to record a YouTube video (not copywrighted). When I have the Audio Host set to MME I get a flat line recording - no input. Recording Device is set to Stereo Mix (RealTek High Defi). The RealTek Stereo Mix Default Format (in Sound->Recording->Properties->Advanced) is set to 2 channel, 16 bit, 48000 Hz - the only other choice is 24 bit, 48000 Hz.

When I set the Audacity Audio Host to Windows WASAPI and hit record, I get the error message: “Error while opening the sound device. Please check the recording device settings and the project sample rate.” I set the Audacity->Edit->Preferences->Quality to match the 16 bit, 48000 Hz settings of the RealTek Stereo Mix. Still no love.

As an added item, the Recording and Playback meters in Audacity show variable green up to about 48 without any applications producing sounds on the computer. That might be just background noise but I’m not sure.

I haven’t tried updating the RealTek driver because, as near as I can determine, I have the latest at However, there is a cryptic comment in the Sound->Recording->Stereo Mix->Properties->Controller Information->Properties->Events->Information: “Device HDAUDIO\FUNC_01&VEN_10EC&DEV_0288&SUBSYS_10EC0191&REV_1000\4&dcc60be&0&0001 requires further installation.”

Any ideas on how I might fix this would be appreciated.

Did your Surface Pro 3 previously have Windows 8.1?

Use your favourite search engine to add an extension to your web browser that can download the video. Add FFmpeg to your computer then you can drag the video into Audacity and FFmpeg will extract a copy of the audio for you, in as good a quality as it already is.

Only having one rate is unusual.

Have you tried uninstalling the sound device in Windows Device Manager? Then type:


in the Start Screen or search box, and press ENTER on the keyboard.

In the window that appears, type:

shutdown /s /t 0

then ENTER again.

This does a traditional cold boot which lets Windows start with a new kernel session. Windows should then reinstall the built-in sound device.

If that does not help, download and run this MSI installer for Surface Pro 3 .

Change the Audacity recording device to (loopback) for whatever speakers or headphones device is playing the video.

Quality Preferences only sets the default sample rate for a new project. What the Audacity project bottom left is set to now is what matters when you actually press the Record button.

44100 Hz may work better for Windows WASAPI loopback. For that loopback input, the relevant default format in Windows Sound is that for the playback device you are using, not that for stereo mix.

Yes, probably just noise.

Try using WASAPI loopback after reinstalling the sound device and if needs be, running the MSI installer (as above).

As a last resort you could see Missing features - Audacity Support where there are a couple of generic Realtek drivers listed. Those may not have stereo mix. Don’t be tempted to try that first.


Have a look at How to download YouTube videos without installing any software