Windows 10 same problem on 2 different PCs

Hi. I have used Audacity for recording listening activities for English classes for sometime. I recently downloaded the latest version to use on my home PC. After I recorded I tried to delete and edit. As soon as I hit the backspace button the software hard locked.
I messed around with drivers and tried to fix the issue. Eventually, I gave up and install Audacity on to a brand new laptop. At first I had no issues. I managed to edit and cut and paste. Then I finished work, however, I got a message telling me the file had failed to save. So I opened audacity again and checked my work was OK. It was fine, but now the software is hard locking when I hit delete on this new Laptop. I have not changed any settings and nothing has been added to PC.

Does any one know why this is happening?


Sorry I forgot to type the version number. The issue happens with the 3.04 version. I tried installing older versions and the issues still occurs.

When I use Audacity, I close every program (app) that is running and not needed, as often, these compete with resources that Audacity needs.

I always close my internet browser, and disconnect from the internet. This prevents programs phoning home In the background, checking for updates, and eating into resources.

In addition, I close Photoshop, desktop publishing, Foxit reader and all open folders.

Audacity itself is not a resource hog, but working with very large files does have an impact on resources.

Being methodical as above goes a long way to having a successful, trouble-free session.