Windows 10 - Internal PostAudio error with Audacity 2.1.1

Hello Audacity-Forum,

i have an strange issue with Audacity 2.1.1 and Windows 10. When i start Audacity i recieve the Internal PostAudio error and no sound devoces are recognized. But when i use an older version of Audacity like 2.0.3 all sound devices are recognized proberly.

I installed the latest driver for my motherboard and soudn devices from the MSI Website. So i use the latest driver for my system. I tried to reinstall Audacity 2.1.1 and with an configuration reset but the problem still exists with Audacity 2.1.0 and 2.1.1. Does anybody know an fix for the latest AUdacity version on Window 10?

Thanks in advance,

I have solved my problem! I removed my rode podcaster from the device manager and rebooted my computer. After that i let windows reinstall the audio driver and voila Audacity 2.1.1 recognize all of my sound devices.

Are those latest drivers stated to be for Windows 10? If you go into the Windows Device Manager, right-click over the sound device, choose “Properties” then click the “Driver” tab, what is the date of the driver?

Audacity does not (officially) support Windows 10, though Audacity works if you have a sound card driver that it can use. As it is working out, it seems some manufacturers’ drivers meant for Windows 10 are not understood by current Audacity, so it is then a question of finding some other driver that Audacity can use.

I have a three year old HP machine for which (so far) there is no Windows 10 audio driver supplied by HP. The built-in audio device is IDT. HP’s Windows 7 IDT audio driver is recognised by Audacity but HP’s Windows 8 IDT audio driver gives the PortAudio error in Audacity.

It may be worth going into Device Manager regularly, right-click over the sound device and choose “Update Driver Software”. When I did that yesterday it appeared to update to another IDT driver, though in fact it is the same driver version number and date as the Windows 7 driver I was already using. Windows Update did not offer that driver.

That (supposedly updated) Windows 7 driver behaves like the Windows 7 driver I was using before. Audacity 2.1.1 recognises it but its stereo mix is disabled. Because I am using Audacity 2.1.1 I can use Windows WASAPI (loopback) host in Audacity instead of stereo mix.

Anyone who has a Realtek audio device might possibly find that a recent generic Realtek driver is usable with Audacity 2.1.1 on Windows 10. Only try this as last resort, because it is in principle better to obtain a driver from your computer or motherboard manufacturer’s site which will be exactly matched to your hardware. Here are two links to generic Realtek drivers that some users have found to work with Audacity 2.1.1: - Obtain the 32-bit or 64-bit drivers according to if you have a 32-bit or 64-bit system.


Thanks for letting us know, though I am not quite sure of the details. If you removed Rode which I assume is a USB mic, Windows would only reinstall drivers for Rode, unless it already had new drivers ready in Windows Update for your built in audio device. Are the drivers for the built-in audio device new?

I do have a hunch that on some machines it is possible that an incompatible driver for one device could prevent all the devices from being recognised, but it should not happen and it is only a hunch. Anyone can test that by selectively removing devices and restarting Audacity.