Windows 10 - ASIO - Works on Windows 7 not Windows 10

Hi! I’m running Windows 10. I compiled Audacity 2.1.2 with ASIO support. It compiled successfully as if I run it on a Windows 7 box, Audacity opens right up (with ASIO support)

If I run it on the Windows 10 box, that I compiled it on, the splashscreen comes up and then closes without a trace.

I ran some procmon.exe while starting it on the Win10 box and it seems to hit Audiodg before cleanly exiting threads and then itself. Nothing obvious in the procmon output but I do need to dig into that a bit deeper.

If I install Audacity 2.1.2 from the packaged binary / executable you provide, that one starts up fine (though obviously no ASIO support which I need).

Before I get into further procmon hell though, any ideas on where else I might look? I’m wondering if I need to try code from the 2.1.3 branch instead?

Not sure if this is a compile issue or a Windows issue but trying this section first :slight_smile:

Thanks for your time!


2.1.3-alpha (latest code) uses a later PortAudio version. It may be worth trying for that reason, but no other changes we’ve made since 2.1.2 are likely to be relevant.

Why do you need ASIO support - for multi-channel recording or for a specific audio device? Can you post Help > Audio Device Info… so we can see your devices, or tell us what they are? If you are using external audio devices, do they have correct Windows 10 drivers and firmware supplied by their manufacturer, and have you tried disconnecting the devices to see if that makes a difference?

If you use Windows WASAPI host in 2.1.2, latencies should not too bad, especially in Windows 10.

Audacity 2.0.4 ( supported Windows WDM-KS which performs almost as well as ASIO but there is a chance that support will crash your computer. We dropped WDM-KS because of those crashes.


I need ASIO support for both multi-channel and a specific device: Tascam US-1800. Using Audacity 2.1.2 compiled with ASIO driver and it works perfectly in Windows 7 (recording our band with it all :slight_smile:

With our without the Tascam connected, in Windows 10, ASIO-compiled Audacity will not open.

I’ll keep playing around and will report back with anything useful!

Thanks for all you do here!



If I compile without ASIO on Windows 10 - everything is fine.


Do I have to use the Steinberg ASIO driver? Would asio4all work? I’ll give it a whirl

I would expect that given you said the pre-compiled 2.1.2 launches on Windows 10.

To use an ASIO4ALL driver, Audacity must still be compiled with ASIO support.

I don’t know if ASIO4ALL will solve the problem that Audacity doesn’t launch. That “could” be some other problem, like a security app interfering. Have you installed a third-party anti-virus?

ASIO4ALL won’t give you the low latencies that ASIO will.

You could also try compiling the latest HEAD development code: but that will only help if the later PortAudio version somehow helps.


Okay, I can run ASIO compiled Audacity if I stop the “Windows Audio” service (Audiosrv). It runs and obviously only has the ASIO device(s) available…which is fine for my needs as the Tascam is both recording and playback device.

Interesting eh?

Is this in 2.1.2 or 2.1.3-alpha?

It’s possible 2.1.3-alpha will run without the Windows Audio service turned off.


Hello anyone,
Our church records its services for broadcast on a local radio station. Currently using Audacity but need to go to multi-track (at least 4) for a better mix. I am not a computer programmer and don’t understand what the “compile ASIO” stuff is about. We have a nice Soundcraft Multi-track board (12 channels) but the drivers do not allow any more than the 2 channels on Audacity. I tried Reaper which gives me all the tracks I need but is too complex for the avg church volunteer to operate. Does anyone have any ideas? Thank you. Direct replies welcome.

You can try changing Audio Host in Device Toolbar to Windows WASAPI or you could try Windows WDM-KS host in Audacity 2.0.4. Please note 2.0.4 might crash your computer if any audio devices on your computer do not support WDM-KS. Explore all the recording device options in Device Toolbar. There may be a “multi” device or similar name that records all the channels.

Otherwise you must use a DAW that supports ASIO or compile Audacity with ASIO support. You must not distribute that ASIO build to anyone else. Perhaps the IT Manager at your church could help you?