Windows 10 1803 Update Issues

Nothing which is critical, at least on my systems, but Microsoft’s latest attempt at confusing us is being rolled out. When you right click the standard speaker icon in the task bar the previous audio devices options ( playback and record ) are now just sounds. This takes you to the old control panel where you can see all your audio devices as before. Note that any previous settings, in particular disable all sound effects may be turned on again so in most cases you will probably want to turn it off for devices which Audacity uses. You will also find that the right click option mentioned above is easily confused with the similar sounding option open sound settings which goes to a new style settings menu which can only see active devices and not ones which are connected but switched off, although its possible to jump to device properties or sound control panel in some cases. I also found that the tool tray link for my RME device control had disappeared until I did another reboot.
I probably haven’t discovered all the niggles ( or improvements ) so if you spot anything audio related please add it to the post.

Since installing the Spring Creators update I cannot record. I get the error message ‘Error Opening Sound Device - Try changing audio host, recording device & the proposed sample rate’. I’ve tried all the solutions out there but still doesn’t work. I’ve enabled all the devices, clicked to show disabled devices, checked the sample rates and all the devices are working. I can playback recordings. I’ve tried loading older versions of Audacity but nothing works. Any ideas?

Not related to the 1803 update then. But what is the input device you want to record from? If you look at the windows recording device properties try using the listen tab listen to this device to see if that works ( keep the volume low to avoid feedback if it is a microphone ). Try one of the free simple recording apps to see if its just an Audacity problem.

Thanks roadsterUK. It is the 1803 update which I assumed was the Creator one. I’ve gone into input properties for Stereo Mix and ticked the listen to this device box and then clicked OK. Nothing happened. Did I follow your instructions correctly?
If it helps the playback is through Speakers(Realtek) and the Input is Stereo Mix (Realtek High Def Audio). Really appreciate your help on this.
If I can’t get this to work can you recommend an alternative streaming audio recorder.

I installed the 1803 update, not the creators update, and I can’t record anymore, I get 'Error opening device. Try changing the audio host, recording device and the project sample." I tried changing all those things but it doesn’t help.

See if this fixes it:

Thanks steve, that worked. I checked the Microphone settings on Windows and it said ‘Microphone for this device is on’ but ‘Allow apps to access your microphone’ was off so I turned it on and that did the trick. I don’t get it because there is a list of apps under ‘Choose which apps can access your microphone’ and Audacity isn’t there but it still worked.

Thanks Steve it worked for me as well. I looked at the microphone settings but as Audacity wasn’t listed I didn’t make any changes. I really appreciate the support I’ve been given.

Just confirming: I screwed around with this for hours until I finally hit a thread that talked about TURNING ON THE DAMN MICROPHONE in Win10 settings, as it had been turned off in the most recent update.

This sticky thread:


OMG, thanks derekwhitman and waxycylinder - I finally got Audacity to work again!! The mic was indeed disabled in Privacy, and I’ve spent several hours changing every darn thing according to other help sites… Thanks sooooo much!

ive spent four nights this week trying to figure out this problem. even went and bought a new sound card.

NOTHING worked.

Then i see this thread and FINALLY A FIX!


Anyhow, thank you so much.