Will not record USB speakers in Windows 7

I am using Audacity 2.0.2, but have had older versions with the same results. I’m running W7 and use USB speakers, USB headset and just recently (after 2+ years) figured out how to record from any source) what is playing on my system. Last week I plugging in my speaker that came with the system to the Line In Jack on the Computer, then right click on the sound icon in the task bar, select Recording to bring up the Sound Menu, then right click on Realtek High Definition Audio (or whatever your system uses to provide sound to the Line out Jack), then right click on it, select Set as Default Communication Device, click OK. Then in Audacity I select the Stereo Mix RHDA as the microphone for input. My (cheap) speaker has a volume control on it for listening while recording that is independent from the Sound Control in the Task Bar meaning I don’t have to turn the volume up/down as desired for the speakers while recording, But I did turn the volume all the way up (left click the Icon for the Sound on the Task bar) and it determines the level that is being sent to what’s being recorded. Unfortunately Audacity does not for some reason recognize my USB speakers as an option for recording. Though once I want to just listen to some GOOD sounds I then go back and right click the sound icon, select Playback, select my USB Speakers to Set as Default Device and I’m happy. Do keep in mind that with the volume set all the way up while recording, those recordings are going to be louder than what it was while capturing the recording.
I’m willing to bet that this method will work in other versions of the OS’s, though to get to the controls may differ somewhat.
Good luck and happy recording,
D Man
PS: I checked the notify me when a reply is posted if I left something out

I started a new topic for you since this seems to be about USB speakers.

We find it hard to understand what you are saying.

Any reason why you don’t use the current 2.0.5: http://audacityteam.org/download/windows ?

Why would you plug an output device into an input port? Does that port convert between input and output?

That will be because USB speakers are an output device not a recording device. Also because they are a separate device from Realtek, the Realtek stereo mix cannot record the USB speakers. Realtek can only record audio playing through the Realtek device.

What method is that? Did you have a question or were you imparting a pearl of wisdom for us?


I’m not using the current 2.0.5 because I haven’t been using Audacity often due to the fact it would NOT record as desired and felt no need to update.
In the comment I mentioned that I plugged in my speaker that should have said to the “Line Out - (not Line In). It’s not an input device. In the past I never had
anything plugged into the Line Out as I used the USB speakers and USB headset.
The reason for my original comment was in reply to how to record with Audacity with W 7 (or similar topic) from a member.
Bottom Line (no pun intended) if there’s nothing plugged in to the line out port, for some reason My Windows 7 Home Premium/and/or Audacity or an idiosyncrasy
with my Dell Inspiron 580S that does not recognize the Stereo Mix (RHDA) as a source for recording and it will flat line. Having searched the WWW I realized I’m not
the only one to struggle with using Audacity to record. Sure, it works fine with a mic for voice recording, but recording with the mic sitting next to the speakers
for what is streaming does not get the quality desired, and not to mention any interruptions from other sounds in the area.
If and when I finish the screen shots I’LL post them.
I hope this is helpful,
D Man

You should not need to plug speakers into the line out to record stereo mix. That is almost certainly a problem with your Realtek sound device or you need to reconfigure Realtek.

To prove that theory you should set stereo mix as Default Device on the “Recording” tab of Windows Sound then see if you can record computer sound in Windows Sound Recorder with no speakers connected to line out.

If you update to 2.0.5 then you can also try choosing the Windows WASAPI host and the “loopback” input in Device Toolbar . This method of recording computer playback does not rely on Realtek for making the recording.


On the contrary, I’ve read the Realtek manual (less than very helpful in my opinion) for configuration. I did install Audacity 2.0.5 earlier this month on another computer my mom uses that is respectively identical (less memory) to this one I use, and found to have the same results. I have to have the speakers plugged in and have to set RDHA as Default Communication Device & set it as Default device in the Recording Tab, and in the Playback Tab RHDA needs to be set as Default Device with Audacity. The settings in Audacity will only record with MME (Windows Direct Sound is not satisfactory, and get an error message (sample rate> blah, blah, blah with WASAPI).
Gale, you may be able to help better knowing my System Information so I’ll attach that and maybe I’ll be able to listen through the better speakers while recording in Audacity.
Fingers crossed,
D Man
System Info Clip.PNG

When I had working desktop computers with no built-in speakers on Windows 7, it was possible to record stereo mix without hearing it by unplugging the speakers connected to audio out. One of those machines had a Realtek sound card, but it’s possible some machines may require an output to be connected before sending audio. You should ask Dell about that, if you don’t see any options for this in Windows or the Realtek control panel.

If Windows Sound Recorder shows the same “problem” you can’t blame Audacity.

We’ve never understood what your aim is. Is your aim to record computer playback without hearing it? If so, buy a 1/8 inch TRS jackplug and put it into the audio out, or plug in headphones there and turn the volume down.

If you could get WASAPI to record then it would record even if you turned the output device volume down to zero. Does WASAPI record if you plug the speakers into the audio out?

If the “better speakers” are USB speakers, I already explained that you cannot record those with Realtek stereo mix, because the USB speakers are a separate audio device to Realtek.

In principle you should be able to record the USB speakers using WASAPI loopback. Choose the USB speakers in the second box in Device Toolbar and the USB speakers (loopback) option in the third box in Device Toolbar.

I can’t see your Windows audio configuration or Realtek Control Panel from your system information. However I suggest you visit this page http://www.dell.com/support/drivers/us/en/19/Product/inspiron-580s where you can install the latest “Realtek ALC887, v., A00” audio driver for your system. Sometimes reinstalling the driver and rebooting the computer can help, even if the current driver is already installed. But it won’t help if the sound card is designed not to play unless an output is connected.


Have you tried closing Audacity down, plugging in or switching on your speakers, then opening Audacity?
I don’t often use the forum, nor do I bother with new features unless someone mentions them, so after posting my reply, I opened my Audacity & checked all the features & found the one in the screen shot, Don’t know if it helps you but as they say at Asda, “every little helps”

As far as I can understand this topic, the issue is not that Audacity fails to recognise whatever speakers we are talking about.

But I agree if there is no playback to the built-in sound device without plugging the speakers in, you might have to restart Audacity or use Transport > Rescan Audio Devices before the speakers are recognised. You will always have to restart or rescan after plugging in USB speakers.

Thanks, but Sound Activated Recording is not relevant to activating a device. What it does is pause and unpause recording in response to the strength of the input level, pausing if the input level is below the set threshold.

As I understand it, the stereo mix recording is made (doesn’t remain paused) but records silence. This is expected if the user is trying to record playback from USB speakers because there is no playback going through the Realtek device.