Wierd Sound with Microphone..

Hey all

I’ve been having trouble with my recordings recently, ever since I got my new mic. Whenever I try to record acoustic guitar with the mic (Apex 530 Condenser Mic) it makes weird sound I can’t really explain. I need to let you listen. http://download1098.mediafire.com/r1nab79111wg/n9u912riclbykm2/weirdsound.mp3
My friend has told me that it is because the plates in the mic dont vibrate the same as the strings on my guitar but I just need to make sure with the experts here, and how I can fix the problem.

My mic is an Apex 530 Condenser Mic (as i’ve said above) connected to my mixer (Behringer XENYX 502) with an XLR cable, my mixer is then connected to the microphone jack to my laptop. My soundcard is SoundMAX Integrated Digital HD Audio. I’m running on Windows XP on an IBM T60 Thinkpad.

The abrupt decay and distortion sound like “echo cancellation” artifacts.
Switch off “echo cancellation” if you have it on. It’s probably in “microphone properties”, or some Skype-type VOIP program.

Do you know where I can find microphone properties?

I don’t have XP myself, but here are the directions … http://www.tinyeye.com/avsetup/soundsetup_xp.html

I suspect “echo cancellation” will be found in the “advanced” “sound recording” properties …


I can’t click the advanced button on there…:frowning:
Echo Cancellation is not in my Recording Control Properties either…

You may have to enable the “advanced” option here …

(I don’t use XP, I’m not sure :confused: )

Alternatively there may be “echo cancellation” controls on the sound card control software, rather than the XP controls.

I just Googled “SoundMAX Integrated Digital HD Audio” “echo cancellation” , it looks like that sound card does have echo cancellation.

When I check it the only “Advanced” option it gives me is Microphone Boost

Then the control to switch the “echo cancellation” off should be in the software to control your sound card. Have a look in “all programs” for something with the same name as your soundcard.

BTW I’m 100% certain the weirdness is due to echo cancellation, it’s partially correctable with extreme dynamic range compression …

Ohh it sounds better!
Where would you find extreme dynamc range compression?

It’s not a fix: compression won’t fix the distorted bits, it just makes the quiet bits louder.

You need to switch that dammed “echo cancellation” off.
My soundcard controls can be accessed by clicking on this Sigmatel thing in “hardware and sound” …

Your sound card has a different name. If you see anything in “hardware and sound” with “soundMAX” click on it and hopefully it will then give you an option to switch echo cancellation off.

e.g. …


I do have the SoundMAX option in my control panel. It brings me to the SoundMAX control panel with options like
Microphone Setup :
Standard Microphone (i selected this one)


Microphone Enhancements:
No Filtering
Voice Recording (i selected this one)
Speaker Phone

Unfortunately there isnt any echo cancellation :frowning:

But you are recording guitar music, not voice (a.k.a. speech).

Echo cancellation is only used on voice recording (VOIP, e.g. Skype), try UNselecting “Voice Recording” in “microphone enhancements”.

IT’S FIXED!! :slight_smile:

Thanks so much! I just changed it from Voice Recording to No Filtering.
Ahhaaa I am so happy :slight_smile:

Here is the end result:

Thanks again!

[I added attached copy of “weirdsoundfixed!.mp3” as mediafire link not permanent].

Bonus track using Colonel Trebor’s secret blend of 4 different effects , (although none of them hiss noise reduction, which it does need)

I went through the Audacity Noise Removal wiki and it’s step by step tutorial with images.
This is really a kind of excellent tutorial. I wouldn’t have done it without going through
this tutorial. Also huge kudos for the Advanced Tip at the very wiki. I have also downloaded the Bonus Remix. :wink:
Note: Mediafire link is deleted now.