Widget Bug Error and weird thumpins

Windows 7 Ultimate, Audacity 2.3 (er, the latest one)

Problem started with recipient telling me there was a weird thumping noise in my files. (Almost as if my computer wishes I played rap). I was showed the isolation, but it’s… not… here… Seriously I literally cannot find it here, so I downloaded the latest versions and reinstalled audacity, LAME, FFmpeg, and am about to put in a new version of Noisegate just in case.

All of a sudden I get the attached error, which upon looking I have no clue what to do about. So being as this is upon an update/install…

I’m also told the thumping remains.

Also error report attached.
Audacity_dbgrpt-4400-20181127T171418.zip (101 KB)

Do you recall what you were doing when this error occurred?
Are you able to reproduce the error?

Yes, I’ve recreated it frequently. It happens when I export the file: either mp3 or wav, doesn’t matter.

I went in and disabled a bunch of plugins I never use, hoping that would work with no change. I also downloaded and installed the latest wxwidget, no change. I have no idea if this is effecting the final file or not, because I can’t find the thumping to begin with.

I suspect that the thumping is unrelated to this error message.

Are you using the “Use custom mix:” option? (Import / Export Preferences - Audacity Manual)

Well apparently I was, although I’d never changed those settings in that particular part of the program. I unchecked it and the error has stopped.

Sure wish the thumping problem were this easy. LOL

That’s good, but still, that error should not happen.
Were you exporting a stereo track when that error appeared? I’d like to be able to reproduce the problem (if possible) so that we can discover what the underlying problem is.

I’d suggest that you start a new topic for that one, and include a short audio sample in WAV format to demonstrate the problem (see here for how to attach an audio sample: https://forum.audacityteam.org/t/how-to-post-an-audio-sample/29851/1)

Well with the error going away, so did the thumping apparently. So strange.

I have the settings on:

export to MP3
“force mono” checked (it was already recorded in mono, however)
constant, 192 Kbps