Why some (but non all) recordings loses completely bass?

Hello friends.
In my Acer E1-522 laptop, the sound card is Realtek high definition audio, with a default sampling rate of 24 bit, 48000 hz. In my Audacity 2.3.3 I set the same parameters: 24 bit, 48000 hz.
At the beginning I had Windows 7 64 bit but now I have Windows 8.1 64 bit, original and updated, I think it works perfectly.
I record music from Youtube with WASAPI Loopback, which captures audio directly and digitally from the sound card.
Now I have an unpleasant problem that I am unable to solve:
some, but not all recordings lose the bass and sub-woofer frequencies, although in the original version the bass is there.
This is what happens: after recording, when I export the song in MP3 format (at 320 kbps), some songs play completely without bass (for example, bass and drums)
I tried to play that exported song on my computer, with my good earphones, and on my MP3 player: in both cases there is a total absence of bass.
Sometimes the exported songs play correctly but after a few seconds the bass disappear.
Whether listening to the tracks exported to my laptop (with earphones) or to my MP3 player, in both cases some tracks are completely without bass.
On 64-bit Windows 7, Audacity 2.3.3 worked perfectly, never lost the bass frequency
Anyone have the same problem?
Has anyone already solved it?
Thank you!

Sounds like a case of destructive-interference.
Possibly the stereo is (accidentally) being mixed down to dual-mono,
or Windows audio enhancements is allowing some crossover between left & right.
(i.e. turn-off playback & recording enhancements)

Sometimes there is a Windows setting for “laptop speakers” that cuts the bass so you don’t badly distort the sound when playing on the tiny built-in speakers. I can’t tell you where to find that setting because it’s a “feature” added by the laptop manufacturer (or maybe by the driver developer) and different computers are different (plus, I never had Win8).

But if the problem shows-up on your computer and on your MP3 player, that’s not the issue.

As you say, WASAPI Loopback should be “accurate”. MP3 compression shouldn’t be throwing-away bass either, but you can try WAV as an experiment.

…This is unlikely, but there is a certain wiring-defect (in your speaker or headphone wiring or connections) that can make a “center channel vocal remover” effect, and that will remove everything in the “center” (everything that’s identical in the left & right) including the bass.

Or, some “stereo widening” effects can also kill the “center” when played-back in mono. You could run into that with stuff on YouTube.


with a default sampling rate of 24 bit, 48000 hz. In my Audacity 2.3.3 I set the same parameters: 24 bit, 48000 hz.

Not related to your problem but it’s advisable to leave the default “quality” setting of 32-bit floating point. The conversion to floating-point is lossless (and reversible) and there are advantages to using floating-point for “processing” and temporary storage. I believe the sample rate will default to match the stream you are you are “capturing”. When you export to MP3, there is no “bit depth” because MP3 doesn’t store the individual samples.

Thanks very much.
I will try to manipulate Realtek Driver to turn on “full range speakers” instead of “small speaker”.
I hope that this will solve my problem.
Bye, friends :slight_smile:

Hello Friends!
I solved my problem myself, but I think is important to share solution with all of us.
The low cut frequency that occours when Audacity is recording with WASAPI Loopback is independent by sample rate or another configuration like “small speakers” or “full range speakers” on Realtek high definition driver panel.
I discovered this: unplugging headphone while recording a song, Audacity cuts immediately all low frequency.
Plugging o re-plugging headphone, Audacity restores immediately the correct sound with low frequency.
To better analyze situation, I opened a web page where is a tone generator, I generate a 100 Hz tone and recorded it. I set 100 Hz because was impossible to play with internal laptop speakers (at least needs 200 - 300 Hz to be heard)
Also I tried to set, during recording, the “full range speakers” on or off, but nothing changes.
At least on my laptop, with windows 8.1 is necessary to keep headphone plugged in to have low basses on recording. Otherwise, realtek driver cut automatically low frequencies to adapt with internal extra small speaker (to avoid distortions) and, in my case with windows 8.1 that the only way to work.
With windows 7, at the same configuration settings, the problem did not exists, maybe due to another version od Realtek drivers.
Thanks very much for support.