Why do I get "NoOverwritePromptz1msAL"

Why have I recently started getting this message on a Mac using macOS 10.15.2 :


Is there something I didn’t click that caused this? Is it an Audacity vs Catalina thing?

What is the full and complete message?
When does it occur?

NoOverwritePromptz1msAL is the full message and I get it whenever i make an edit (in this case change of volume) to a track already in my iTunes folder.

Which version of Audacity are you using? (look in: “Audacity menu > About Audacity”)

“Recently”? When did it start happening? Was Audacity running correctly previous to that?

I first noticed it around two weeks ago. And everything was running fine before that.
I’m using Audacity v

Do you record with Audacity, or just edit?

How do you launch Audacity?

Is your Mac set for automatic updates?

I just edit and mostly volume changes.
I launch it from an icon either in my applications folder or from the dock.
No the Mac is not set for auto updates.
Why would any of this be a concern?

Because current versions of macOS Catalina do not allow applications to run that have not been approved (“notarized”) by Apple.
Audacity has not been notarized by Apple, though the next version (Audacity 2.4.0) will be.

I’m curious how you manage to launch Audacity from the dock, because Apple’s “Gatekeeper” should stop you. How have you worked around that?

We do have a related known and logged bug

Mac: Custom FFmpeg Export and (external program): unwanted “NoOverwritePrompt” dialog and file


“I’m curious how you manage to launch Audacity from the dock, because Apple’s “Gatekeeper” should stop you. How have you worked around that?”

To be honest I’ve no bluudy idea. I’ve just always done it that way.

Try launching Audacity as described in this post, and see if that makes a difference: https://forum.audacityteam.org/t/audacity-2-3-3-under-macos-10-15-catalina/54279/1

I will certainly try it in the morning (when I have a few more brain cells active.) But I’m curious as to why you think it will do anything when it seems specifically for folks who record using Audacity which isn’t me?

I’m making an educated guess. This is my thinking:

The error message is not from Audacity, so it’s probably from macOS. It appears to be indicating that Audacity is not allowed to do something, though the error message is so vague I’ve no idea what precisely macOS is objecting to.
Because Audacity is not “notarized”, it is not possible to directly give permission to Audacity to access computer resources.
“Computer resources” include access to the microphone, access to files and directories, access to other apps and services …
The workaround for accessing the microphone will “probably” also work for other computer resources, hopefully including whatever is causing your problem.