White Noise is All-Consuming

Hi, all. I’m having a lot of trouble figuring out where all of my white noise sounds are coming from. I have played with the gain A LOT, but I’m still getting awful results.

I recorded a sample according to the guidelines here, which is much louder than I usually do because it makes the hiss so audible (and also that echo…). The sample has the preamp gain set at 85/100 and the audacity recording input level at 90/100.

I am using a Blue Spark mic (the analogue version) with the focus button pressed. The preamp is an M-Audio M-Track. I am using Windows 10 and a Dell XPS 8500.

Any advice on how to improve this situation would be much appreciated. I’m not sure what is failing or how to test things anymore.


It sounds like you might actually be recording from your laptop built-in microphone.
As a test, start recording, then gently scratch the grill on the mic with your fingernail (don’t “tap” it - that’s not good for mics). The sound of scratching the mic grill should be loud and clear if that mic is on.

Oh, I notice that is a desktop computer.
Do the scratch test anyway, if the test fails then there must be another mic somewhere.

Hi! So a few developments:

  • Soon after I made that recording, I realized that I had turned the microphone backwards while tinkering with the XLR cable. So the recording you hear is of me speaking into the BACK of the cardioid mic. WOOPS. That is probably why my voice sounds so awful, but I don’t think it accounts for all the white noise (which is present in other recordings I have made even with the mic turned the right way).
  • I then placed the mic into the correct position and plugged the preamp into my macbook pro. I made a recording (preamp gain at 75/100 or 85/100 and audacity recording input at 100/100), and it did not have any white noise. None that I could detect. It sounded like a very clean recording to me. I almost cried.
  • It seems like there is something going on with my PC’s set up (sound card???). For various reasons, I MUCH prefer to record on the Dell XPS 8500 if I can figure out a way to do so without the background noise. Based on what I’ve described above, does this help diagnose the issue any further?

(Also, do let me know if you still think I should do the scratch test.)


Yes, please do the scratch test and post the result.

Hi, I have attached the scratch test and also an updated audio sample (with me speaking into the mic correctly). Thanks so much!!

The scratch test is certainly working :wink: but the huge signal level shows that your recording level is very high.
How close are you to the microphone (lips to mic distance), and how is the “focus control” set?


  • My mouth was ~6 inches away from the mic.
  • The Focus button reduces low end sensitivity and instead “focuses” on low and mid frequencies (http://www.bluemic.com/products/spark/). It is literally an on/off button, so there is not much else to set.

I can include a recording from my macbook pro so you can hear the difference if that helps at all? Let me know what you think could be useful.

Thanks again.

A recording from the Mac could be useful. Is that exactly the same setup apart from the computer?

I don’t hear any excessive noise on your samples. There is some noise, but with gain setting on the M-audio at 85% I would expect that to be present. It’s a bit of white noise from the preamp and some ambient noise from your recording room.

Your mic has an output of 28 mV/Pa. That is very high. I’d expect the M-audio not to need 85% gain, more like 50 or 60%. Are you sure you are not recording with the input set at line level?

Are you using the original (Avid) M-Audio M-Track, the current plastic M-Audio M-Track, the plastic M-Audio M-Track+, the newer metal M- Audio M-Track 2X2 , the newer metal+plastic M- Audio M-Track plus II or the newest metal M-Audio M-Track II? (all of these are 2 I/O).

Have you listened back to your recordings made on the PC on another computer?

The original Avid M-Audio M-Track had a driver problem with certain Windows versions that made it noisy on playback. Trying older/newer drivers seemed to fix that. But I haven’t seen one of these in many years. And for these drivers, you still need to go to the Avid website.

Don’t know about the newer ones from M-Audio, but the specs seem to indicate a lot of difference quality-wise, especially the S/R, which varies from -104 dBu to -96 S/R ratio on mic inputs. 8 dB is a lot, especially as they don’t even care to tell us how much gain the preamp offers… The only one I found gain numbers for, the M-Track II, has 55 dB gain for mic, line and instrument inputs… That hardly sounds correct…

Hi, steve, here is an audio sample with the same settings on my macbook pro (EXCEPT audacity greyed out recording inputs on the audacity software whereas they were 90/100 on the pc recording). Also, I meant to say that the focus button “focuses” on the highs and mids. Woops.

cyrano, this is the preamp I have. The plastic M-Audio M-Track | Two-Channel Portable USB Audio and MIDI Interface (24-bit/48 kHz ). There is a mic/line-guitar switch, but I’m not sure how to differentiate the input? I’m pretty sure the computer is reading the input as a mic based on what it says when I open the recording settings. And yes, I have listened to the recordings I have made on my phone as well as on my macbook pro. They all sound pretty bad, even after some (admittedly basic) mastering. I can search for new drivers if you think that might be the cause?

Thanks. There’s not a huge difference there. The Mac version has more hum at 120 Hz, but less hiss above 400 Hz.

I think we should be able to get Windows to work a bit better. Have you tried getting WASAPI to work?
Note: Write down your current settings before you change them, with pen/pencil and paper. You currently have settings that work reasonably well, and if we can’t get it working better, then you will want to return to the settings that you have now.

I’m referring to the “host” settings in the device toolbar.

WASAPI is a newer and potentially better option than MM" or directsound, but some sound card drivers don’t support it very well, or perhaps not at all. What we’re trying to achieve is a path from your USB pre-amp to Audacity, that is as direct as possible, so that the audio data that Audacity receives is identical to the audio data that comes out of the pre-amp.

The sample rate set for the pre-amp in the Windows Sound Control Panel should be the same as the sample rate in Audacity. Set them both to 44100.

When you select the recording and playback settings in the device toolbar, you DO NOT want the “loopback” options. You may need to resize the device toolbar so that you can see the names properly (click and drag the right hand edge of the toolbar).

Enable both “Exclusive Mode” options in the Windows Sound Control Panel for the pre-amp USB device.

If you can get this working, I think that you will lose the input volume control functionality (same as on the Mac). That’s OK because you should be using just the level controls on the pre-amp.

Try that and let us know how you get on.
Don’t forget to write down settings before you change them :wink:

Thanks again, steve! Those settings were all in place, but I had been recording with Windows DirectSound, so I just made an audio sample for you with Windows WASAPI. I see that the levels are definitely too high, but I’m not sure if I should adjust it on audacity (it’s still not greyed out) or on the preamp – or both.

By the way, when I listen to the previous pc and macbook pro audio clips on studio monitor headphones, the white noise in the macbook pro clip is much less noticeable to me. Maybe it’s because the clip is quieter overall? But it sounds much more ideal to me than the previous pc clip does.

That’s a large part of it.
When normalized to the same level, the low frequency noise is a similar level on both machines. The mid to high frequency noise is lower on the Mac, but the Mac also has an additional hum at 120 Hz. If we can get the mid to high frequency noise down a bit on your PC, then we win :slight_smile:

Ooh, that’s looking better.

As an experiment, turn up the recording level in Audacity to maximum, and turn down the input level on the pre-amp (the physical hardware knob) to minimum.
Then activate the recoding meter in Audacity by clicking on it.
Start talking, and gradually increase the level on the pre-amp until the peak level in Audacity reaches -6 dB on the meter. (The meter can be stretched wider so that it’s easier to see).

If you need to “reset” the meter, click on it twice (first click turns it off, second click turns it back on).

When you have the levels set as above, make another test recording.

Hi, so I think I recorded at the levels you wanted, steve. Let me know if it’s not right.

I ended up using 20% in the preamp (and kept Audacity at 100%) for the recordings below. As an experiment, I used a different XLR cable for a different recording to see if that made any difference (included below). To my untrained ear, it sounds less “noisy” but I can definitely hear a high-pitched electronic-sounding hum. These are all raw wav files, but when I tried to get rid of the hum for practice, I could not.

I also played around with reducing Audacity’s levels and increasing the preamp’s gain, which is how I had previously been recording things – and the noise seems to diminish (at least to my ears) when I do this. But I’m not sure if that’s a smart thing to do or if it ruins sound quality.

Thanks again!

Thx. I don’t know if this one needs newer drivers. And since the change in XLR cable already made a solid difference, I think that’s where we should point our attention.

Using 20-25% gain also sounds more in sync with what I’d expect from a high output mic. And there’s no setting for line input to get confused about.

Thanks, cyrano.

What do you think my next steps should be?

Changing the USB cable that connects the preamp to the computer? Getting a new preamp?

  • I downloaded the M-Audio drivers for the preamp since I realized I was using Microsoft’s, but I have to turn the gain to 85% to get a decent level, which seems wrong (this is with Audacity’s recording input at 100%). Not sure if I should revert.

I’m sorry, I’m completely ignorant when it comes to Windows 10.

It seems as if Windows is trying to manage your recording level somehow. Have you had a look at the settings in Windows?

Hi, I gave up on the M-Audio preamp and got a Focusrite Scarlett 2i2. The electric whine is gone, but there is still some noise. The Audacity input settings are at 100%, while the Focusrite is set to the 3 o’clock position (which I guess is like 75%). I’m not sure, even with mastering, if I can get something like this to pass a human at ACX since I still hear noise even after very minimal noise reduction (I don’t want to do too much since you’re not supposed to do any).

cyrano, my Windows settings don’t look out of the ordinary I don’t think.