Whirring ball every time I edit

I’m editing a 15 minute episode of my podcast, almost finished, but now, every time I attempt to edit, copy, select, cut and paste to refine the timing, I get the whizzing ball. And often, after several minutes, the WARNING that automatic backup failed to safe. I’ve been using Audacity for 20 years, have the very latest Version, 3 month old iMac 20 with Ventura. I only have one day left to get it done. Please help. I’ve looked at other similar posts, nothing quite matches. I have tried Save As, Save Backup, close down Audacity and open again, restarting the computer.

Early advice would be most gratefully appreciated.

Curiously, see this post and posted solutions: Painfully slow when pasting audio

Thanks, but that is a Windows fix, and I’m on MacOS Ventura. All the Windows suggestions say to turn off Autosave in Preferences. I cannot find anything there to turn it off.

Why do you say that ?

Because I assume that’s why the features they mention in the Windows forum are not available on my Mac. Or if they are, I need more help to find them!

I even tried a search in the Audacity online manual for “Automatic Data Backup” and nothing comes up. Nothing comes up for ‘save’ or ‘auto save’ either.

Cheers f

So anyway, I wouldn’t steer you that post if I didn’t believe it had a solution to your issue. It may actually be worth reading.

Sorry Jade, I didn’t explain myself well. I did read the post. Worth reading, but it didn’t solve my problem.
Thanks for your help.

If you have tried Mix and Render and it doesn’t fix your problem, then if you care to zip up your project and post it, I’ll take a look at it to see what is wrong.

That is so kind of you to offer. However, once the project is mixed, it’s no longer possible to edit individual tracks, which is what I was trying to so when the software began to be troublesome. Fortunately, I had enough of it more or less done, and I was able to re-record the final few minutes into a separate file, and then mix that, and attach it to the original (mixed) file). So the episode has been published. Only not to the quality of editing that I would have liked.

But still, I have to record new episodes, with multiple tracks, and I need to be able to edit them without having to wait several minutes in between each edit while the software decides whether to complete my edit or not.

I’m going to try reinstalling Audacity itself, in case some bug has crept in. Fingers crossed!

Take care, and thanks again. f

So if you have a chance to take a break, copy the project, then try a mix and render on each individual track and see if that doesn’t fix the issue.

SO if you do this try reverting to 3.1.3 or wait a couple of weeks until 3.3.0 comes out.

Regardless, good luck. :grinning: (And my offer still stands…)

Thanks again. I’ll have a play with your suggestions when I get a moment.

All the best!

It sounds like you MIGHT want to check the health of your hard drive/SSD.

If it’s giving those errors, it means read/write operations failed somewhere along the line.

You might also check running processes in the background to make sure they’re not eating up all the disk access time.

Thank you. I’ve just done a check, in accordance with instructions I found via Google. This is what it says


Free: 60 MB (59,994,112 bytes)
Capacity: 195.2 MB (195,166,208 bytes)
Mount Point: /Volumes/Audacity
File System: HFS+
Writable: No
Ignore Ownership: Yes
BSD Name: disk8s1
Volume UUID: D48C9C12-6B67-3AF4-88A0-582968895F95
Physical Drive:
Device Name: Disk Image
Media Name: Apple Disk Image Media
Protocol: Disk Image
Internal: No
Partition Map Type: GPT (GUID Partition Table)

I have absolutely no idea what this means. But it does seem significant that Audacity is the only software that features in the “storage” window, along with “Data” “Macintosh” and “Watch OS simulator”

Any thoughts?

Audacity does not do automatic backups, so I don’t know where this message is coming from.

That’s the Audacity “disk image”. Are you running Audacity from the disk image? That won’t work. You need to install Audacity by dragging it from the disk image into your Applications folder.

Hi there, Whenever I’ve had this issue, I have had to export the project (in AIF or WAV format), and then import that (AIF/WAV) file back into Audacity. If you’re working with multiple tracks, perhaps you can export each track individually and then import the resulting AIF or WAV files back into audacity and work from those. I’m not sure if this is the perfect solution but it works for me every time.

Sorry, I think I replied to the wrong person. In any case, I hope you found a resolution and I didn’t create further confusion!!

Your hard disk or SSD may need to be checked for health, based on how it sounds.

If it is displaying those problems, read/write operations must have failed at some point.

To make sure they are not using up all the disk access time, you may also check background processes that are now active.

Thanks, no worries. It all helps!

Thank you! Turned out, it was in both places. I’ve deleted the disk image, and new files seem to be ok. But that one I was working on, is definitely corrupted. Thanks for your help.