While recording cannot hear the sound of the source

I was browsing the forum for “no sound while recording” and found a few posts none of which actually solved my issue.

I am using audacity 2.0.2 (installed from the Pacman repository) on opensuse 12.2 x86_64 using the KDE desktop. I am recording vinyl records using a record player that is connected to a phono preamp which in turn is connected to the PC’s “line in” jack. For output I just use some PC speakers connected to the “front” jack of the PC.

To start with, I list the things that work:

  • I can record tracks with audacity.
  • I can play recorded tracks from within audacity.

What does not work:

  • While recording I cannot get audacity to play the recorded sound simultaneously (i.e., monitoring the recording).

What I have tried so far:

  • In audacity under Edit/Preferences I have checked (under the recording / playthrough section) “Overdub: Play other tracks while recording new one”. Result: That seems to work in so far, that an already recorded track, that is open in audacity’s recording window, is played (i.e., I can hear the sound of the already recorded track) but the sound of the track that is currently recorded cannot be heard.
  • In audacity under Edit/Preferences I have checked (under the recording / playthrough section) “Software Playthrough: Listen while recording or monitoring new track”. Result: Recording does not work any more. I.e., after pressing recording button a new recording window pops open, but the recording button becomes inactive immediately and no sound is recorded. Pressing recording button again just opens additional recording windows and recording button becomes inactive again.

Hope someone can help.
Thank you

PS: As a side effect of closing the Preferences window with ‘OK’ results in audacity’s toolbar items disappearing (only the File menu item is visible half-way). After closing and restarting audacity all the file menu items are shown again. This is rather an annoyance than a major issue.

Try setting “Transport > Software Playthrough” to “enabled” (selected), and set the “recording input” and “playback output” devices in the Device Toolbar to your sound card , which will probably be marked as something like xxxxxx (hw:0,0).
Ensure that no other audio applications are running.


I just tried it and it works now as expected. Thank you very much for your help.


For information. what I think was happening was that the options “default” and “pulse” used PulseAudio to connect to the sound card. It sounds like PulseAudio was stalling when Audacity tried to connect to both the input and output or PulseAudio at the same time. The (hw:0,0) option bypasses PulseAudio. This has the disadvantage that the sound card will probably not be available to other applications while you are running Audacity, but it tends to be more reliable and more stable for Audacity,