When Audacity v3.0.5 is running, Finder actions (e.g. Cmd-O, double-click, …) do not open project file

Hi everybody!

First of all, I want thank the developers that helped to fix the latest bug („Opening a project file via keyboard shortcut Cmd-O deletes the project file“)! The bug is fixed in v3.0.5. THANK YOU VERY MUCH!

I found one more thing though…

I tested on my system at home and noticed a minor project file opening error (which is not dramatic, but present):

When Audacity v3.0.5 IS NOT RUNNING, opening a project file form the Finder via
– Cmd-O
– double-click and
– open with…
works fine: the project file is opened in Audacity.

But when Audacity v3.0.5 IS RUNNING, opening a project file form the Finder via
– Cmd-O
– double-click and
– open with…
does NOT work fine: the project file is NOT opened in Audacity.


macOS 10.15.7 Catalina
iMac (Retina 5K, 27 Zoll, Late 2015)
3,3 GHz Quad-Core Intel Core i5


ffs! And let me guess, when you change your Audacity language to English, everything works fine again?

made a bug out of it anyway: https://github.com/audacity/audacity/issues/1781

That is correct, but only if OS language is set to English AND the decimal separator is set to “decimal point”, then opening works fine.

BTW: Both above settings must be chosen. If one of them is not chosen, it does not work (on my system).

Audacity v3.1 fixed this problem (so far, I only tested on macOS 10.15.7 Catalina)! Many thanks to all the people involved!

The new functions (moving clips by dragging, no repositioning when deleting a part of a track, trimming clips, looping) are F***ing awesome! THANKS for making Audacity yet more complete!

Where do I have to send my xmas money to? :wink:

[…hiding behind a rock…] ahem, correction: it does not work yet again. I tested it not correctly yesterday. sorry! unfocussed me, myself and I …

Little update info (to whom it may be of interest):
Version 3.1.2 does not fix the problem discussed in this thread.

On my Mac, version 3.1.3 did solve the problem that a file won’t open at all when I double click on it. That’s now working. Thanks!

What is still not working, is double clicking on the file (or use ‘Open with…’) when Audacity is already active. In that case I first have to close Audacity and open it again by double-clicking the file