Weird playback behaviour on Audacity


I use Audacity 2.2.1 daily on Xubuntu 18.04 LTS, with a Behringer USB soundcard UCA 222, linked to a mixing console.

After some minutes or hours of use (it’s random), if i type on the spacebar in order to play the track, the playback suddenly speeds up a few seconds then it comes back to normal speed, and it’s very very annoying. Because of that bug, i can’t work on my project :imp: and the only way i found to resolve it, is to reboot. Therefore i have to reboot at least one time per day.
I don’t use Jack (i don’t need real time in my case). On another computer which also runs under Xubuntu 18.04 , with also an USB mixer and Audacity 3, the same thing happened too.

CPU : Ryzen 5 1400
Ram : 8 Go
Motherboard : MSI A320M-A PRO

Any idea ?

It could be a bug, but to be honest I can’t remember that far back. Xubuntu 18.04 is close to EOL (end of life), and the current version of Audacity is 3.1.3

Ubuntu 22.04 was release last April, which has Audacity 2.4.2 in the repository.

There’s also an AppImage version of Audacity 3.1.3 available from the main Audacity website (Audacity 3.2.0 AppImage is due to be released soon).

Hello, i use Audacity daily for my work in a radiostation. Since several months, i have a really annoying bug on Audacity i can only fix with a computer reboot.

the bug appaers in version 2.2.1 under Xubuntu 18.04 LTS but also in version 3

In fact after a certain time of use, the sound is going ultra fast and is really crappy when i clic on play and a few time after becomes normal again. I tried to record a video from my desktop but it didn’t work sorry.

I use a Behringer UCA 222 soundcard in USB, with a MSI motherboard A320M A PRO, AMD Ryzen 5 1400, 8Go RAM, 1To Hard drive

Used with Alsa (no need to use Jack, it’s not real time audio)

the phenomena also appears on other computers with USB sound cards too with same OS…

Any solutions ? because it’s really really BORING.

Thanks a lot.

Hello sorry i didn’t remember i had already written this topic, i just post a new one on exactly same subject but i can’t delete it. Sorry.

Well, i stay under 18.04 because i need an access with Samba v1 and 20.04 doesn’t seems to work exactly as expected.
But i tried the Audacity 3 and, same bad thing. I will just try again now, in order to see if it comes from the old audacity version.

My collegue who don’t use USB card but exactly the same mobo and OS has the same problem.

I doubt that it is caused by Audacity as I used a UCA-202 (almost identical to the UCA-222) for several years on Xubuntu 18.04 64 bits without ever seeing the problem. (I now use Xubuntu 22.04 LTS).

Perhaps a problem with the USB connector or USB lead?

Topics merged.

which suggests that it might be an issue with that particular mother board or its drivers in 'buntu 18.04.