Weird error message with Windows 10

When I tried to play a recording I made on Audacity (I am on windows 10) I got the following error message. While I think I solved the problem just afterwards, by switching from Speakers (Synaptic HD Audio) to Microsoft Sound Mapper - Output I still wanted to ask for help here.

Admittedly the fact that I had just took those screenshots for the purpose of asking the question here, right before I thought of the workaround probably influenced that line of thought.

P.S. I just checked. I have Audacity 3.0.4

Does everything else play, such as steaming internet media, mp3 music and Windows system sounds?

I haven’t tried to open any of those in Audacity.

Congratulations on getting it to work. I’m glad you found a solution that worked for you, although I would have thought that you could output directly to your speakers. Sometimes people have different results by changing from MME to Windows WASAPI.

Sometimes there is an issue uncovered by running “mmsys.cpl”, then opening the Playback tab, selecting your device, then Properties, then other tabs, including Advanced. It is not clear that anything in there would have changed your circumstances. Sometimes there is another device that is interfering. Sometimes rebooting can help…