Waveform mouse scrolling using Shift+mouse well STOPED WORKING in windows [SOLVED] (X-mouse button setting)

Hi guys,

I am having this issue coming form Ubuntu to my windows machine.

I don’t remember the version i have at my Ubuntu machine.

I have Windows 10 fully updated (27/07/2018) and installed Audacity v 2.2.2 .

From the begging the mouse scroll witch i am used to, doesn’t work. When i am pressing Shift key + moving the mouse wheel, nothing happens. This is forcing me to use the scroll-bar witch is taking me so much more time, because i am alway zooming in and out of the waveform.

All i can see is that the play + record buttons are changing when i press Shift 9i don’t remember it happening in Ubuntu, but i 'm not sure).

This has make the program almost unusable for me, even in the preferences in the mouse section i can see the command, but it doesn’t work.

Is there something that i have turned on that’s blocking this behaviour? I will loose my mind …

I just found out that when you press Ctrl + Shift + mouse wheel, it’s scrolling!

I leave this for others to to be helped.

But why make such a change? Can I revert it back?

At least the menu entry must be corrected!

I’m looking for a preference or preset that turns Shift-Scroll on and off and I don’t see one.

OK. I found it in Audacity > Edit > Preferences > Mouse.

Screen Shot 2018-07-27 at 6.36.00.png
Does yours say that? Does your zoom work?


Well it says exactly as yours. Can you scroll though?

I found the solution! i Posted also a screenshot, forum said it will be “auditioned” first and then uploaded…

Also, can’t i edit my own post?? What’s this? i want to put [SOLVED] in the end and i can’t.

Ok !!

Let’s flood this post, because i cannot edit my post, and my posts doesn’t appearing. Probably they need to be posted by someone wore reputable in the forum.

Although i understand this system, it’s not so appealing for new users of audacity. If i can post a new post directly, why am i NOT able to directly answer my own, or any other’s ?

Any way, that menu is not intended to be changed the mouse menu is only for reference, here’s a nice proposition for 2.3.


Fresh, new users are moderated and messages have to be viewed by a forum elf before they appear.

For a while.

So don’t double post and try not to scattershot your posts. It’s rough to keep up.


My 2.2.2 Shift-Scroll works exactly as it should. The post is not resolved because your machine does not work as expected. You’re experiencing a desperation method work-around.

Does that zoom work?

What other Apps do you have currently running that could capture or scramble the keys?

Does it still do that if you Shift-Shutdown your machine and start it fresh? Do Not let anything else start. Windows 10 Shift-Shutdown is a clean shutdown that takes longer, but resets more settings.


Hmmm, interesting.

Well the zoom works ok for first.

It’s a lot programs i use, i 'll start closing them down to see what’s causing the interference, and come back at you.

I was ready to answer, but i though i try “X-mouse button control” (using it to switch to between virtual desktops like compiz in ubuntu).

So i found it! You were right it was blocking shift some way. I found out that deactivating the “make scroll wheel scroll window under cursor” under settings, returned the default behaviour in Audacity.

Thank you for your assistance Koz.

Glad to help.