WASAPI not working with 7.1 USB headset

Problem 1 - Loopback recording:
When I try to loopback record something with my 7.1 USB headset, audacity gives me a sample rate error. Ok. So I go to Help → Diagnose → Audio devices trying to find the compatible sample rate. Thing is, there is literally none. It just doesn’t list any supported sample rate whatsoever.
Ok, so I search a little bit and find out it’s a recording channel thing. I change mono to stereo recording, but it also does not work. Now the error is not sample rate, but simply 9996 Invalid Device.
The only way to make it work is selecting 8 recording channels, which is absolutely insane.
I don’t know why this is happening, because I could totally use this headset before. This all started to happen when I upgraded my PC and had to install everything over again.

Problem 2 - Playback device:
Selecting 7.1 USB device as a playback device just never works. At all. Even if I record some random audio with my mic and try to play it with WASAPI. Just no. The error I get this time is “Can’t open audio device. Please verify the device settings and sample rate of the project”. I tried multiple sample rates/bit rates combination but none of them worked.
P.s. everything works just fine with MME or Windows DirectSound. My only goal here is to be able to record my PC audio properly through audacity (then hear it again).

Sometimes changing the Audacity project-rate from the default 44100Hz to 48000Hz is the cure.

Hello. Unfortanely, I have already tried to do that but with no luck.

This topic was automatically closed after 30 days. New replies are no longer allowed.