WASAPI error

The following procedure results in the error:

Error opening recordeing device
Errorcode -9997 Invalid Samplerate

I open Audacity. Select WASAPI. Set the proper number of channels(4) as set in Win10. Then I record. This works fine. Then I hit stop. When I click record again it gives me the above error.

When I try to play the recording straight after stop it gives the error:

Error opening the sound device
Try changing the audio host … etc.

switching the host is somewhat cumbersome, but I can play the four tracks. Recording four tracks in MME and DirectSound is not possible in Audacity, although with portaudio based PyAudio it works fine.

Is there something to change somewhere?

Audacity 2.4.2, Win10, UMC404HD with driver:


Do you need the 4.59 driver ? See Overdub help with 2.4.2 - #8 by emptymountain

That would not allow me to record 4 tracks: Behringer UMC404HD 4-track recording [SOLVED]


A couple of ideas:

I hope this helps. :smiley:

Yes. Looked at it once more. All set the same, but … I noticed that in the UMC control the input bitdepth is set at 24 &4 channels and is greyed out. I can find no what to set it to 16. So, changed everything else I could find in Audacity and Windows sound control panel to 24 and it works. Anything else than 24bit & 4 channels does not work under WASPI.

I’ve looked at that in the past. May be worth a try. Will it also give me multichannel on MME and DirectSound? PortAudio seems to support it. It works with a few Python tools. It may depend on the compiling process.


I am glad you found a solution to your issue. :smiley: Thanks for posting back here your solution. :smiley:

Yes, when you compile with ASIO, you have ASIO as an additional host option, so Audacity now has four (4) hosts to choose from: DirectSound, MME, WASAPI, and ASIO. For me, the only ASIO device that shows is my Behringer. This made it tricky to listen through my laptop. So I then added Asio4All which allows the headphones to also be used via ASIO. :smiley: