Warnings compiling VST Enabler

Hi, I’m trying to build the vst bridge, and I get this:

g++ -Wall -O9 -I. -I…/vstsdk2.4/pluginterfaces/vst2.x/ -shared -o vst-bridge.so vst-bridge.cpp
vst-bridge.cpp: In member function ‘bool Plug::Init(long unsigned int, char*, AEffect*, AEffect*)’:
vst-bridge.cpp:1023: warning: deprecated conversion from string constant to ‘char*’
vst-bridge.cpp:1024: warning: deprecated conversion from string constant to ‘char*’
strip vst-bridge.so

I apologize if it is something silly, I’m a musician with little knowledge in this matters, so I would be very thankful for any help.

Is this for Linux?
For other platforms the VST enabler is a binary and does not need compiling. If it’s Linux, then sorry, I don’t know. You’re probably the first person on this forum to ever try that. The most successful way I’ve come across for running VST effects on Linux is to use Reaper in WINE as the host.

Hi Steve, thanks for the reply.Yes, I’m using Linux.

I edited vst-bridge.cpp:

mDesc.UniqueID = id;

mDesc.Label = GetStr( effGetEffectName, name );
mDesc.Name = GetStr( effGetProductString, name );
mDesc.Maker = GetStr( effGetVendorString, name ); <------------ |___originally set to “None”
mDesc.Copyright = GetStr( effVendorSpecific, name ); <------------ |

No warnings now (silly after all).

Excellent - how well does it work?
Fancy writing any tutorials / tips for Linux users? It sounds like you know what you are doing and we are rather lacking in Linux expertise on the forum.

Ha ha ha, that’s funny.I’m just starting with linux, and all this compiling thing.I really don’t deserve any credit, like I said, it was a silly thing.It would’ve worked regarding those warnings.However, if I can be of any help at all, I’d be glad to.
I don’t know if I should continue here.Perhaps if it is useful it can be moved later?.
I’m not much of a teacher or tutor or whatever, so…

First of all, the vst enabler does NOT work with DLL (windows) VST, I’ve seen confusion about this in several places.
There are open source VST’s, therefore they can be ported.An example: mdaPiano.dll ----> windows
mdaPiano.so ----> linux

There are some native Linux VST’s, also (some info here: http://www.linux-vst.com/).

For DLL VST support on linux applications there are two options I’ve seen:

—> fst — http://www.joebutton.co.uk/fst/

—> dssi-vst — http://dssi.sourceforge.net/download.html

Of these two I’ve tried dssi-vst, haven’t got the time
to test a large number of plugins (I don’t use a lot anyway), just a couple of aradaz and karmafx.

A tip: you can load multifxVST (— http://www.kvraudio.com/get/1068.html —) with dssi vsthost, then you have a graphical host with preset support, etc.

I’ll try compiling JOST with built-in linux vst support.
There’s a way to communicate windows apps to linux ones using wineasio and jack, also, gonna try that too.
Maybe I’ll post results later if someone is interested.

I for one would be very interested in getting Audacity working properly with JACK.
I got it to work in a fashion using Audacity 1.3.4, but with some fairly major issues.

Currently I’m using the “Intrepid” (Ubuntu) build of Audacity 1.3.5. It works very well with ALSA, with very few issues, but completely no-go with JACK, in fact just running jack is likely to crash this build of Audacity.

I hadn’t tried audacity with jack, as I use it more like a wave editor, don’t need it to work with super low latency.I tried it after I read your post, to see the results.

I started audacity, went to audio preferences, no jack on dropdown menu; so I started jack then audacity, and there it was (maybe you know how to make audacity start jack?).I started playback and it worked just fine.Then I started ardour at the same time, to see if something crashed: everything fine.I started mplayer,audacious and qtractor (with audacity and ardour still running, of course, all playing something, not a pleasant audition :slight_smile:): no crash, no xrun, everything ok.

I got audacity 1.3.5 from getdeb.I use Ubuntu Studio Hardy (32).

Do you have any idea of why does it crash on your system?, maybe we can find the problem doing some comparisons.

No, I’m not particularly bothered about the super low latency either. It’s the virtual wiring - hooking it up to other Jack applications that interests me. Running Hydrogen through Jack Rack, adding a bit of reverb, compression and Eq, then recording with Audacity produced absolutely “Rockin” drum beats :smiley:

The application that I found it did not like at all, was Jack Control (Audacity 1.3.4 built from source on Xubuntu 8.04). Usually I use Jack Control for starting Jack and linking everything up, but instead had to start Jack from the command line to set the sample rate, then shut down Jack. Opening Audacity would then start Jack at the same sample rate (which I would have previously selected as the default for Audacity. Opening “Patchage” would not show any presence of Audacity, until Audacity was in Play, Record, or Pause mode. As soon as Play or Record were started, Audacities outputs (and inputs, if Record had been pressed) would suddenly appear in Patchage, allowing me to hook it up to other applications.

I’ve not had time to try building Audacity 1.3.5 from source yet, and may wait until 1.4 comes out unless I suddenly find I have some spare time on my hands. The stock 1.3.5 build for Ubuntu Intrepid just causes massive xruns and is not at all stable if I try to use Jack.

I did use jack control.Maybe if you try (if you haven’t) the getdeb build?.