Voxformer Issue Audiobook Deadline Apr 29!! Please help!!

I just downloaded the version 2.3.1 and now Voxengo Voxformer won’t load! I even went back to version 2.3.0! I have one chapter left to edit for my audiobook and it’s due on the 29th!

At first I got the ‘Effect failed to initialize’ error.

After fiddling I finally got Voxformer to show in the Plug-ins but I get this:
Effect or Command at /Users/williamsturdevant/Library/Application Support/audacity/Plug-Ins/Voxformer.vst failed to register:

Please help!

Audacity 2.3.1 is a 64-bit app. Previous versions of Audacity were 32-bit.
The 64-bit version of Audacity requires 64-bit plug-ins. 32-bit versions of Audacity require 32-bit plug-ins.

As you have a deadline, it will probably be easiest to go back to Audacity 2.3.0 until you’ve finished the current project.

I got it to work after reinstalling the latest versions of everything but now the Limiter is not working. It’s there as an option and the settings are correct but when I run it, it does nothing.

I presume that you are referring to the Limiter that is shipped with Audacity: https://manual.audacityteam.org/man/limiter.html

If so, a good way to test it (start with a new, empty project window):

  1. Generate a “Chirp” (Generate menu)
  2. Amplify it to full track height (default settings)
    The track should look like this:

First Track000.png
3) Apply the Limiter to the track with these settings:

The result should look like this:

First Track001.png