Volume Not Adjusted Properly with Envelope

Audacity: 2.4.2, 3.0.0
Intention: Mix two similar-themed game tracks in succession, then copy them to lengthen the track for at least 30mins.
Expected: Envelopes on each end for a seamless custom cross-fade between the two tracks.

Problem: Actual volume in some envelopes does not follow the degree of envelope I set it to.

If the selection during the time I saved the project is reserved (Trackname: option3, 06:02 to 06:08), it should show this.
Audacity GFL envelope problem.png
The volume should lower down as set in the envelope. However, around 06:05.100, it returns to its maybe-default unenveloped volume. Changing the envelope’s degree, even on its lowest point, does not fix things; it only seems to move the time which it will, in the case of lowest envelope point, disrespect the envelope on around 06:05.700.

When I delete the rest of the succeeding copies of that track though, it seems to fix itself. Once I copy it back though, the problem returns.
Playing/Highlighting only up to the portion of the audio, the volume seems to follow the envelope. Highlighting beyond that, it loses its grip to control the volume properly again.

Problem footage: https://youtu.be/NVrhc5buDoE
Linked is the aup3 of the tracks I’m working on.

Very peculiar.
I’m glad you posted the video - that illustrates the problem very well.

I suspect there is a “phantom” envelope point stuck in the track somehow :confused:
Unfortunately I’m not able to view the AUP3 because it is set to “private”.

I swear Mediafire’s got silly permission nuances; it allows me to share link, but it doesn’t, like, set the thing automatically to unlisted/public.
Anyway, I’ve set it to shareable; it should be accessible now.

I was suspecting some kind of a phantom envelop point too, but that’s still odd knowing it follows the envelope properly when the selection doesn’t exceed the track.
…and it shouldn’t have to do that in the first place anyway; if it were a phantom envelope elsewhere, it shouldn’t affect what’s already enveloped! >3<
Anyway, hoping that the sample could point to whatever bug it is, if it is.

This isn’t the first time I’ve experienced it with some of my custom crossfades using envelope, too; though I couldn’t replicate it manually w/o going through my usual Audacity activity.

Got it :slight_smile:

I’ve found something peculiar in the project. There are several “zero length” audio clips. :open_mouth:
I’ve observed this previously in some projects, but I’m unsure what causes it - of course this “shouldn’t” happen.

Do you recall what effects you’ve used on the problematic track?

I’ve found a workaround to fix the project, but could you leave that project available for a while - I’d like the developers to take a look at it. There’s clearly a bug somewhere that caused the problem.

The workaround:

  1. Click on the track’s “Select” button.
  2. “Edit menu > Clip Boundaries > Join”
  3. “Edit menu > Clip Boundaries > Detach at Silences”

Note that this will remove splits from within continuous sections of audio, but will restore empty spaces.
Check the track thoroughly before saving the project.

Aaa this workaround works! Thank you!
I think, for the most part, I can leave the saved project as-is to preserve the clips, then just apply the workaround on my finalized export. (technically I can reproduce the clips but eh effort atm.)

Zero-length audio clips…I may have encountered that in a few projects, too, with varying symptoms such as unable to move selected tracks even after having clicked the track name to “select all of that track”.

As far as “effect” goes, only Effect>Adjustable Fade>Cosine Out, and that applies only to the end of the track. I then generate 1.000s silence immediately next to that fadeout.

No problem!

If you mean left / right with the Time Shift Tool, then yes, that’s the same issue (and that’s where I first encountered the problem).

We have fixed some cases that can create zero length, or very short (single sample) clips, but it seems there are some other cases that we have not discovered yet.

I’ll take a look at that and see if I can produce any zero length clips.

Oh yes, and could you leave the video up for now as well. I’ve sent a link to the developers to illustrate the problem.

How do you make the selection? (in excruciatingly precise detail please)

  1. Select a time in the track where it’s supposedly looped (doesn’t have to be a boundary of a clip). Luckily, this track does loop exactly on the clip [Track1 named “m_sf_recap_intermission 1L”, 30m08.792s].
  2. Move cursor/starting point by +2.500s in the Selection toolbar, via arrow keys ^ ^ > ^ ^ ^ ^ ^.
  3. Select 7.500s via “Length of Selection” in Selection toolbar, via punching the numbers there along with the zeroes by the keyboard numpad.
  4. Apply Effect>Adjustable Fade>Cosine Out to selection. (Other settings in the effect are ignored; just the “Handy Preset (override control)” is considered)
  5. Put focus back in track (it could still be in the Selection toolbar as I use my custom keyboard shortcut) by clicking one of the selection ends, otherwise I won’t be able to use my keyboard shortcut ] to goto Selection End.
  6. Goto Selection End. (in other words, View>Skip to>Selection End, but I tend not to go through that :v)
  7. Keyboard shortcut Shift+K to select from Cursor to Track End.
  8. Delete via DEL key.
  9. Staying on that cursor right after the Cosine-faded track, Generate>Silence 1.000s via keyboard shortcut Alt+(G > S).

At least, that’s the process that goes around when I use the effect. Hopefully that’s alright enough. o-o
Visual representation sample: https://youtu.be/11mCeoqQFVQ

Yes, Time Shift via MultiTool, CTRL + mouseclick & movement.

Gladly; and at least for Youtube I don’t think I’m deleting the video there anyway. Virtually infinite (albeit downsampled) video storage hue :v

Thanks, that’s a nice amount of detail, but I’ve still not been able to create a zero length clip.

If you want to try yourself, I’m using:
“Extra menu > Scriptables II > Get Info”
(to enable the “Extra” menu: “View > Extra Menus (on/off)”)

Then in “Get Info”, select “Clips”.
This returns info about all clips in the project, like this:

  { "track":0, "start":0, "end":4, "color":0 },
  { "track":0, "start":5.68678, "end":10.6868, "color":0 } ]

A zero length clip would have the same “start” and “end” time.

Oohh, there such a thing :astonished:

…I think I see why there’s alot. Since I start from like over-a-minute-length tracks, I’m just basically copying whatever zerolengths it hadm then paste however much times until it reaches 30minsl; basically multiplying the amount.
Though that still doesn’t explain how the zerolengths get created in the first place…

Welp, now I gotta see whenever there’s a zero-length clip produced in anything I do, at least for now.
I’m glad I can at least Alt+RGB—oh wait… Alt+RBG my way to it. :v (Oh heck, of course I can set a keyboard shortcut to it, brilliant! xD)

Short trials, I got no zero-lengths on my short lazy non-precise-timing copy-paste attempts on a certain track, but got one on my normal routine.
The lazy one involved opening 1 audio file, the routine one involved opening two files. (Pardon, I used Brief instead of like JSON, but same label/header applies anyway)

   0 0          0.318776 0  
   0 0.318776   3.95637 0  
   0 3.95637  109.411 0  
Normal Routine
   0   0          0.318776 0  
   0   0.318776   3.95637 0  
   0   3.95637  109.411 0  
>  0 109.411    109.411 0  
   0 109.411    214.865 0

More verbose report to come on my next post, when I get to it; this serves as like an acknowledgment then.