Volume control does not work


I have a new Dell Desktop factory installed Windows 10, Audacity 2.1.2 and I believe I used the .exe installer.

I digitize vinyl records and everything works great except the volume control slider is inoperative. It is not grayed out, it just doesn’t do anything. The volume control on the task bar, near the clock, moves with it but it too has no effect on playback volume. Not sure if it manifested when I upgraded to 2.1.2 or when I got the new windows 10 machine. The record level slider works normally, of course.

I went to Dell and they offered updated audio drivers which I downloaded, and I’ve searched the help forums as best I could, but no changes.

If nothing else, I can control volume using the pot on my external speakers, but the slider is more convenient.

Not sure if related, but when my NAD PP3i A to D converter is plugged in (USB), no sound comes out from other sources such as youtube, win media player etc. Unplug the USB cable, it’s right there.

I’m not sure if the developers have a quick fix or setting to check.

As always, thanks for this great program.

I’m not sure if the developers have a quick fix or setting to check.

We’ll ask if we see one.

Audacity can play to devices other than your soundcard, and the routing doesn’t have to follow Windows. For example, if you plug and unplug your USB sound device, Windows may switch to it and in general keep up with current connections. Audacity won’t. If Audacity is connected to your device when you unplug it, Audacity will go to its default device or something else still active—and won’t come back by itself.

Audacity checks for devices when it starts. You can force a check later with Transport > Rescan… Those are the only two options.

So what is your posted playback device in the device toolbar.



The volume control on the task bar is between the sound card drivers and the operating system (Windows), so that’s not an “Audacity” issue. It’s probably a sound card driver problem.

Sounds like you’ve approached the problem the right way.
Do the new drivers from Dell specifically say that they are for Windows 10? (There may also be 32-bit and 64-bit versions. You must use the ones that match your version of Windows 10).

I’d suggest that you go to the Dell site again, double check that you have the correct drivers for your machine and Windows version, then try updating the drivers again.
After updating the drivers, reboot the computer.
I’m aware that Windows can sometimes be “too helpful” in selecting what it thinks are the correct drivers. “Belarc Advisor” can be a helpful tool for checking to see what drivers are actually installed (http://www.belarc.com/free_download.html).

This is “nomal” - see http://manual.audacityteam.org/o/man/faq_playback.html#usb.

To prevent the NAD converter taking over as system playback device, then while NAD is connected, go to Windows Sound and make your desired playback device Windows Default playback device. Disconnect NAD, wait a few seconds and reconnect it. Now NAD should not take over as system playback device.