Volume Control and Line In

I’m currently in the process of moving from Windows XP to Ubuntu 11.10 (Wubi install). I have a Lenovo Thinkpad T61 with a Sabrent SND-8 USB sound card. Audacity 1.3 and 2 work perfectly in Windows but I’m having some challenges in Ubuntu.

  1. Playback: The only volume control I have is using the individual track gain. The output gain slider has no impact nor does my laptop’s overall volume control.

  2. Recording: Recording with a mic is fine. I can’t capture any sound using Line In although I can hear my guitar (for example) through my speakers.

Thoughts and suggestions would be appreciated.

Thanks in advance.

Selecting the audio input should be available in the “Sound Settings”.

For full control of the sound system you probably need to install and use the Pulse Audio Volume Control (pavucontrol). It is available in the Ubuntu repository so you can install it with either Synaptic or the Ubuntu Software Center.

I’ll give that a shot and report back… thanks :slight_smile:

Using the Pulse Volume Control didn’t work. What I did find is that I can record my guitar/bass with good sound quality by just plugging in the mic input. However, there are things I do using Audacity, such as remote control playback (and lots of other functions) of backing tracks, that work so well in a Windows environment. In thinking about it, I’m just going to continue to use Audacity in Windows and not spend allot of time trying to replicate the functionality in Ubuntu. In the end, I have to keep Windows anyway because of some other programs (like Band In A Box).

Mic input is usually not very suitable for line level input. It’s usually mono (which can be a problem if you’re trying to record a stereo signal) and expects a tiny signal, putting a line level signal on it will most likely cause clipping distortion.

Why can’t you select the line in as input? It should be available in the recording devices list in Preferences → Devices (or in the Device Toolbar).

For my purposes, I always record in mono. I can control the mic input level so clipping isn’t an issue, and I when I tried this, I achieved decent sound quality on playback.

Why can’t you select the line in as input? It should be available in the recording devices list in Preferences → Devices (or in the Device Toolbar).

This is what I’m trying to find out :slight_smile:. It’s set to my USB sound device and the mixer shows it. I can hear the sound being played though my speakers but there’s no capture. If I change the mixer setting from Mic to Line In, my mic doesn’t work… which is good, but the Line In doesn’t capture any sound.

In addition, the only way I can adjust the volume is by using the individual track gain slider. As I mentioned, my Windows version works flawlessly.

I think you haven’t mentioned yet… Are you using pulseaudio or alsa directly? What exact options have you selected for host, playback and recording devices in Preferences → Devices?

I’m using Alsa which is the only option in the drop down box. Both playback and recording are set to USB Sound Device. More specific to recording, it’s set to USB Audio (hw:1,0)Mix:1.

Do you have any other options for USB on recording beside “Mix:1”?

On Windows do you have any control panel to control the input volume level of the usb device?

It’s either Mix, Mic, or Docking Station. There are other options in the menu (Default, HDA Intel, Pulse) but none work. I’ve tried them all.

On Windows do you have any control panel to control the input volume level of the usb device?

The USB sound card is a Sabrent SND-8. It comes with a Windows based mixer that allows me to select and control all inputs.

My guess is that it’s probably lack of support on Linux drivers for that card…

That’s what I think it is. As I mentioned earlier, I still need Windows for certain applications so when it comes to using Audacity, I’ll just use the Windows version. It works flawlessly. I’m hoping that over time, I won’t have to rely on Windows at all. In any event, thanks for taking the time to try and help me sort this out :slight_smile:

Just to continue on this topic, I’m now using Audacity 2 after upgrading to Linux Mint 13 MATE (on a Lenovo T61 laptop). I’m still having the same issues as before however, now I’m looking to upgrade my external sound card for recording for I believe that my issues are related to sound card compatibility.

Any recommendations for an audio interface that would work with Linux and Audacity?

Thanks in advance.

I use a Behringer UCA 202.
It is very basic, just stereo line level in and out. Not even any recording level adjustment (I do that on my mixing desk). It has worked perfectly on every machine that I’ve plugged it into, including Win XP, Vista and numerous flavours of Linux. The sound quality is pretty good as long as the signal level is set appropriately, which with my mixer means setting the level to the top of the green on the meters and only occasionally touching the amber (it clips badly if the mixer level goes into the red).
Other popular devices on the forum are the ART usb pre-amps.

Just as a follow up, I can now record in Linux (LMDE) using a recently purchased M-Audio Fast Track audio interface.