Voice Track Hollow Sound

I recently changed to a Mac Book Pro from a PC to record my radio show.
The microphone is a Shure SM 58 and has worked and sounded great on the PC in Audacity for years.

However my voice tracks now sound terrible with a hollow or reverb type of sound.

I did try a a cheaper mike which sounded even worse. I’m using the Icicle that has a built in preamp and the USB converterwith the Shure mike.

I had hoped that using the Icicle with the Shure mike would sound great but it doesn’t.

I’ve tried changing the preferences in Audacity as well as the equalizer in the effects drop down, but there is no change.
I read the posting in this Forum concerning the tinny audio track but I’ve already tried most of those ideas.
The PC is about 10 years old, was custom built, built has seen the end of it days.
Any help is appreciated. Thanks.

How did you connect your SM58 to the Mac? Most MBPs have no Mic-In like your Windows machine did. Do your MBP connections look like this? Which MBP? 13" 15" 17"?


Audacity doesn’t do anything to the sound during recording. Whatever the computer presents is what gets recorded.

You have an odd configuration. Check one thing. Apple (up left) > System Preferences > Hardware > Sound > Input. Make sure [_] Environment Suppression (I forget the exact words) is not selected.

Then use the Audacity Device Toolbar to make sure you selected your microphone instead of the MBP’s built-in microphone. That’s really easy to get wrong.


Then, after we get the routing and connections right, I can tell you that there is no convenient connection for a Shure SM58 and a MBP.

Or at least none that I know of. MBPs haven’t had a microphone connection in years. Some people have managed to trick the headset connection into doing Mic-In, but that’s not normal.

This is how I do it. You should ignore all the theatrics and soundproofing in these pictures. This is a simple voice shoot I did using an SM-58. I connect it to my tiny Shure mixer to boost the volume and then record it on my 15" MBP. If I was on a Windows machine, I wouldn’t need the tiny mixer.


So answer those questions and we’ll see where to go.


Thanks for your reply, it is appreciated.

The Shure is connected to the Icicle by a cable that converts the XLP mike connection to a USB connection that’s connected to a USB port on the MAC which is recommended by Blue the company that makes Icicle and mikes to be used on Macs. I don’t know the size of the Mac since I’m at work and don’t have access to it now.

BTW I had the same problem when I used a borrowed PC laptop, using the Shure and plugging into the mike connection. My old PC was a customized desktop with a sound card that I assume was of excellent quality. Sure wish it still worked.

I have checked the Sound-input and number of times but have not seen anything close to the Environmental Setting that you mentioned. I’ll check it again tonight.

I have checked the correct mike input in Audacity, so it’s not receiving the built in mike but the Shure.

The Icicle has a built in preamp so it didn’t think that I needed a mixer to boost the level?

Last night I tried Garage Band and had the same issue, though not as bad.

To add to my frustration, my wife as a Mac (not sure of the model) and uses a cheap Logitech combo mike and headphone with Garage Band for teaching classes on-line and that sounds fine. When I tried it on my MAC with Audacity again I had the same problem. I prefer Audacity since I’ve been using it for 5 years to record my show and know exactly how to use it.

Somewhere there must be a setting that I’m missing, but I’ve run out of places to look. The Sound - Input selections on the Mac are pretty limited, so I don’t believe it’s there.

I’m ready to retire the show at this point.

Thanks again.

We can do this, but maybe not this second. I’m more than even sure you’re recording the wrong thing. I’m running out of moxie and need to go to bed. Don’t give up… zzzzzzzzz


If you scratch a fingernail on the mic ball, does that show up in the recording? (checking that you actually are recording from the Shure mic and not the Mac’s internal mic).

Yes, that’s not the problem.
I turned off the ambient nose reduction setting in Sound-Input.

That helped a bit, but still hollow.

Also the mike, SM-58 now seems to pick up all ambient noise, so that’s not a good solution either.

Tried playing with equalization, compression and normalize, also adjusting the mike input levels and the gain on the Icicle, but nothing as changed.

Can you post samples of what it sounds like, with Apple ambient noise reduction on and off. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1 .

Have you tried a different USB port?

You said you changed Audacity Preferences but did not say what you did. Icicle is 44100 Hz 16-bit. Set Audacity project rate bottom left to 44100 Hz. Set recording channels in Audacity Device Toolbar to 1 channel (mono). Open Apple Audio MIDI Setup and set the Icicle to 44100 Hz 1ch 16-bit.

If necessary, Audacity > Preferences, choose Quality on the left and set Default Sample Format to 16-bit.


All the settings are as you suggested, but I don’t hear a difference.

The mike is picking up all the background noise, but I didn’t have the issue with the PC.

Thanks again.

After listening to both samples in a Wave format, they both sound fine. I didn’t listen to them before I sent the files so I can live with this sound, except for the unusual sound when recording.

They sound completely different when converted to a file then when listening through Audacity.

If you have any other advice I’m open to hear it.

Thanks again.

Do they sound fine if you import those WAV’s back into Audacity, solo one at a time then play the soloed WAV? I think the version with ambience reduction “off” sounds better, but they are both acceptable.

From the comments we see on this Forum, MacBookPro is not a good choice for audio production. There are too many quirks and problems. What version of OS X are you using? If it is Mavericks, there are even more quirks with MacBookPro, especially with Audacity. If you installed Mavericks over earlier OS X, try reinstalling Mavericks.

Assuming the WAV’s play OK in Audacity, and the problem is with software playthrough when recording, can you manage without software playthrough? What device are you using for playback? Built-in audio? Is the built-in audio also set to 44100 Hz 16-bit in Audio MIDI Setup?

You could also try using LineIn for software playthrough rather than Audacity.

Also what version of Audacity are you using? See the pink panel at the top of this page. Assuming you are using Audacity 2.0.5 at the moment, you could see if software playthrough in Audacity 2.0.3 solves the problem: https://audacity.googlecode.com/files/audacity-macosx-ub-2.0.3.zip .



Thanks for your advice and when I have a chance to follow up I’ll post.

Last night I finally got a decent test sample that is acceptable sounding so I feel it’s headed in the right direction.

I’m not sure what changed but the hollow sound was gone.
The only issue and it is minor, is the volume level of the voice track, even though the input volumes are at max in the Mac and in Audacity. I can increase them through the Effects dropdown under Amplify so that works.

I’m looking forward to trying your ideas.

Thanks again.