Vocal's over imported Backing track with USB not recording

I am using WINDOWS 10 and Audacity 2.3.3
I have imported an MP3 backing track and I’m trying to record vocals over it. I have a RODE USB mic. I have selected this mic to record in Audacity and have plugged my headphones into the mic itself.
When I go to press record nothing happens. It says “Recording” at the bottom of the screen but track is not playing and nothing is happening on the screen. I can hear my voice come through but don’t see any sound waves coming up on screen.
Can anybody help with this?

What settings are you using in the “Device Toolbar”? (https://manual.audacityteam.org/man/device_toolbar.html)

I have selected the “Rode Podcaster Mic” which I have connected to usb port.
Selected 2 Stereo channel
ans selected the “RODE podcaster headphones”

When I unplug the microphone from the USB port and press record, the software will start to record … the laptop microphone itself will pick up my vocals. But it obviously will also pick up the track that I’m singing along to.

I though that if I plugged my heaphones into the USB mic, plugged the USB mic into the laptop and selected that external MIC in the dropdown list in the devices toolbar…that it should be set up to start recording, but when i hit record nothing at all happens. Except it says its recording at the bottom of screen. But noting is moving or playing?!!

You missed one. If the “host” setting is not “MME”, set it to “MME”. This is the most “compatible” setting.

You need to be careful with plugging in / unplugging because it can confuse Audacity. This is also a common source of problems for the unwary.

When Audacity is launched, it scans the computer sound system to see what devices are available. The devices that it finds are then listed as option in the Device Toolbar. If you plug in or unplug a device while Audacity is running, Audacity does not know that you have done that.

If a USB device is unplugged and plugged back in again, Windows may allocate a different ID to the device when it reconnects. If that happens, then as far as Audacity is concerned, it is a different device and Audacity will not be able to use it.

If for some reason a device has to be plugged in / unplugged while Audacity is running, you need to tell Audacity that you’ve done it. You do that with the option: “Transport menu > Rescan Audio Devices”. This takes a few moments to complete while Audacity updates it’s lists of devices.

You are absolutely correct. That is what “should” happen.
We need to work out why it isn’t happening.

That can sometimes happen if the “host” is set to “WASAPI” instead of MME.

The first two (easy) things to check first:

  1. Ensure that “host” is set to MME.
  2. Try doing a “Rescan Audio Devices”.

If the problem persists, then the next step is to check the settings for the Rode in the “Windows Sound” settings. The device should be listed in both the Playback and Recording tabs. In both, the “sample rate” must be the same (ideally set to 44100). In the Recording tab it must be set to “1 channel (mono)”. I don’t know whether it should be set to mono or stereo in the playback tab, but I would guess “stereo”.


Thank you so much for your detailed reply and all the information!

I have checked all the points that you have brought up and it still doesn’t work!!! Bummer!