Vocal Track shortened when Imported [Windows 10, V2.3.0]

Whenever I import a Vocal mp3, It shortens the audio file to 0.21 seconds, when the actual mp3 is about 2 minutes long. I’ve tried both dragging the file onto Audacity, and properly importing it. I always get the same result. The file plays fine on it’s own, but not in Audacity. I’ve imported another mp3 and a video file on their own just fine.
short file.png

It’s probably not an MP3 or it could be a corrupt MP3.

Check your file with [u]MediaInfoOnline[/u] and paste your results here. If it’s an MP3 it should say “MPEG audio” “Version 1” “Layer 3”…

[Windows 10, V2.3.0]

The current version of Audacity might report an error instead of trying to open the invalid MP3.

Here are the results.

OK, it’s an MP4 (aka AAC) file.

Change the name to .MP4 (or to .AAC) and if you haven’t done so already, download and RUN [u]ffmpeg-win-2.2.2.exe[/u]. After you install FFmpeg you should be able to open MP4 files.

Thank you. I already have ffmpeg installed, but renaming the file worked.