Vinyl to CD New Problem

I was recording a vinyl record of about 54 minutes in length. At about minute 50, it threw away everything it had copied up to that point and started a new file for the remainder of the record. Is there a size limit?

How much free space do you have?
Which version of Audacity?
What is your operating system?

(there are boards on the forum specifically for Windows/Linux/Mac and different versions of Audacity)
Audacity is capable of recording for many hours, subject to your computers capabilities.

XP SP II Home edition
Audacity 1.2.2
480 MB RAM
HD 50 GB way less than half full.

<<<Audacity 1.2.2>>>

Are you sure about that? That is a very early version of Audacity. The versions before about 1.2.4 could have stability problems and should probably be avoided. Can you go get 1.2.6? That is a stable release.

Did you get that Audacity with your USB turntable?

USB Turntable–Symptoms

If you’re on a deskside PC, then you can use the Line-In connection of your sound card (Blue, maybe). If you’re on a laptop…


Actually, I don’t have a USB turntable. I have a Griffin iMic device which has a preamp and connects my standard turntable to the USB port. I have copied other vinyl discs with no problem. The problem occurred with this 54 minute disc. I tried it twice with the same result. The link to Audacity came with the iMic and I just went there and downloaded it. I will go back to the site and see if I can download a later version. Thanks.

I downloaded the 1.2.6 version and that seems to have solved the problem. Thanks again.