Vinyl playthrough works sometimes; other times just beeps

Hello, I’m using Audacity 2.0.5, and I have a peculiar problem.

I recently got the AT-LP120-USB as a birthday present from my friends. I connect it to my Macbook (Mac OS X 10.7.5) and use Audacity to play it through my built-in speakers. A couple hours ago, I tried playing again after a few weeks hiatus and all I got were a bunch of beeps. After clicking random things, it somehow started to work again (I reviewed Audio Technica’s literature and all my settings are configured correctly–I checked multiple times and it absolutely positively did work before in the past). After I finished the record, I closed Audacity and turned off my turntable. Just to make sure it would work again (like a true scientist haha), I decided to see what would happen if I opened Audacity and click “Start Monitoring” with the record playing again: this time, I was back to the original problem. The first second plays the actual music that should be playing, and the rest is just a bunch of R2D2 noises with great amounts of distortion. Can anyone help me permanently resolve this problem?

Open Audacity but leave the turntable out of it. Generate > Tone… > 440Hz, 10 seconds, 0.8 volume.

Play that. Does it play like the oboe “A” in the orchestra, or is it trashed?

Use the toolbar with the device selector (Microphone symbol with the pulldown) and select your built-in microphone for recording. Volume-Down boop, boop, boop your speakers to zero. Start recording and say “hello testing…”, you know the drill.

Stop. Bring the speakers back up and play the track. Did that work?


One note. Once you start Audacity it stops looking for new connections. Connect everything, let it settle and bit and then start – or restart – Audacity. Make sure you’re trying to record from the turntable with that Device Toolbar.


I tried all of that and the record played for about 30 seconds! Then it went back to the beeps/glitches and whatnot. The tone did play and so did the mic test. I connected my turntable then restarted Audacity for it to play for those 30 seconds.

Remember the first instruction?

Open Audacity but leave the turntable out of it.

I was not trying to fix the turntable. I was trying to find out if your computer was OK.

Can you try a different USB connection on the Mac (remember to restart Audacity if you change the connection)? If that fails, can you try a different USB cable?

If the built-in microphone worked OK and both the tone and the voice played back, that means the computer and Audacity are probably fine. That leaves the turntable, the connection and the USB cable.

We usually lean on the fact that most of these quick-transfer turntables are terrible quality and fail easily, but that doesn’t seem to be the case here. That’s a respectable turntable. Can you post some of the distortion? Select a brief music or performance segment that has both clear and then distorted sound. Post it in FLAC. We can all play that and it will give you the maximum number of seconds in the test clip.


Sorry. I had followed all your instructions and presumed that if both of those two had worked, that ought to mean it might have been a momentary lapse with my computer that was now resolved. I apologize.

Here’s a segment of the distortion–I can’t get a play of the way it ought to sound.

Thank you for your welcoming help.

Fascinating. That goes away when you lift the needle?

I think you win the “Nobody’s ever seen this before” prize for the week. Since the Mac seems to be in good health and a serious USB problem would have caused Audacity to stop working altogether, I’m going with the turntable itself may be damaged.

The desperation test is try it on a different computer.


There is another way to get this thing fully operational without the USB cable. Does your Mac have a stereo Line-In like the circle with two black arrows?

Even if you don’t, you may have one connection that can switch between In and Out in Mac Preferences. Some of the smaller Macs had that.

Apple (upper left) > System Preferences > Hardware > Sound. From here, you will have a variety of different panels depending on your machine. Attached is what mine looks like (click the graphic). If you have a 13", yours may be very different.

If you get it to work with the analog pathway, that will be our secret and nobody else has to know.

Screen shot 2014-02-23 at 8.47.13 PM.png

The strange thing is, I’ve listened to records 15 times before this ever happened before. I don’t think it could be the turntable. I do have those Line In and Line Out ports on my Macbook, but how would I connect the turntable through those? I’ve attached what my sound panel looks like.

Even more perplexing is why/how a record played in between these two moments of distortion, perfectly through, then after restarting Audacity, returned to this state. Thanks again for the help, Koz.
Screen Shot 2014-02-23 at 11.55.50 PM.png

You need one of these:

Connect the RCAs on the back of your turntable to the Stereo Line-In of your Mac. Select Built-In Input on the Mac and Audacity. You can lose the USB connection.

Somewhere on the turntable should be a switch to go from Phono-Out to Line-Out. Select Line-Out.

Play a record. Start Audacity recording.

Do you get well-behaved blue waves and bouncing red recording sound meters?
(Your meters may not be this big. I make mine bigger because it’s easier to troubleshoot.)


Just to state a couple of obvious things.

Connect the turntable to a spare USB port, not into a USB hub connected to the computer.

Change the USB cable, try another USB port.

Try resetting Audacity preferences.

Quit Audacity, open Finder, Go > Go to Folder and type:

~/Library/Application Support/audacity/

Open audacity.cfg. Select all the text and delete it. Then type the following at the top of the file:


Save audacity.cfg and restart Audacity.


I’m sorry, Koz, I don’t understand. The RCA cables coming out of the turntable are those exact Red and White cables; I don’t see how I would connect either end to the turntable itself?

Peculiarly, when I went to Finder, I could not find the folder. I went to Application Support and in Library, I have no “Audacity” folder. Is that the problem, potentially?

I can’t tell from the instructions what there is behind the turntable. That was a roll of the dice. It’s a slightly different adapter. I need to go away for a while.

Do you have the Phono/Line switch back there? It may be in front. I can’t tell.

This turntable is designed to be self-supporting and plug into several different music systems, not just a computer. So it’s just a matter of getting all the options to line up.

While I’m looking, go through the steps Gale wrote. You may not need my adapters at all.


Make sure you are looking in your own user Library - the “~/” means your home folder.

Where it says “CODE:” below, click the “SELECT ALL” and copy the highlighted text. After you choose Go > Go to Folder (in the Finder menu), paste in what you copied.

~/Library/Application Support/audacity/


Here it is.

That will adapt the RCA cables from the back of the turntable to the Stereo Line-In of your Mac. You do need to be very careful because this thing puts mechanical strain on the connector in the Mac. The adapter itself and the turntable cables are all hanging from that one little 1/8" plug, but it’s the cheapest.


A much better, less strain (but more expensive) way is to adapt that cable I posted so the turntable fits.

These little things come in packs of 2, which is fortunate because you need two.

You put one on each RCA of this cable.

…and then you can plug the turntable into it. Make sure the reds and blacks line up to keep the stereo Right and Left sound straight.

The lighter cable plugs into the Mac and you can put a book or something on it so it doesn’t pull, twist or turn and damage the Mac by accident. I’ve been known to tape it to the desk. You can do those tricks with the cheap adapter, too, but it’s harder to do and the size of the adapter may be in the way of plugging in headphones.

Have you got too much help yet? :slight_smile: