Version 3.1.3 Won't Import Projects From Previous Versions

I am running Windows 10 64bit which is updated to current versions. I updated Audacity to 3.1.3 back in April 2022 and have found that many of my projects generated in the previous version fail to import into 3.1.3. Explanations are that my AUP files must be corrupt but that turns out not to be the case. I have tried double clicking on the AUP file from Explorer which starts opening Audacity but results in the error. I have also used the FILE/OPEN command and it also results in the import error. I have attached the screen captures of the actual failure notice
Couldn't Import The Project.JPG
and Audacity 3.1.3 Log
Audacity 3.1.3 Log.JPG

I have loaded an older version (2.4.2) on my pc using the “Portable Settings” method and the same AUP files that would not import into 3.1.3, do open successfully in the older version.

It was my understanding that 3.1.3 should import and update these older projects to the new version but it does not work in many cases. I have tried numerous projects and get similar results about 60 percent of the time. Some projects do open, while others do not.

To be more precise, I do not know what previous version I had before the upgrade to 3.1.3 but I loaded it approximately back in 2018. My oldest projects data back to only 2020.
Any and all suggestions are welcome. Thanks in advance.

Try copying the AUP and its “_data” folder to your “Documents” folder and see if it will open from there.

If you still see the same error message, attach the AUP file to your reply so that we can take a check if it looks OK. (See:

If you see a different error message, let us know the full and exact message.

I copied both the aup and data folder to the documents folder (C: drive) and got the same error. AUP file attached for your review.
On Broadway.aup (56 KB)

Try this version:
On Broadway.aup (56 KB)

Yes, that works now. What’s the verdict? I have a bunch more with the same issue.

The problem was caused by this bug:

To fix the AUP files you need a plain text editor - one that doesn’t mangle the formatting or encoding. I’d recommend using NotePad++ which is available (free) from:

Looking at the first few lines in the AUP file:

<?xml version="1.0" standalone="no" ?>
<!DOCTYPE project PUBLIC "-//audacityproject-1.3.0//DTD//EN" "" >
<project xmlns="" projname="On Broadway_data" version="1.3.0" audacityversion="2.3.3" sel0="-7.0078541667" sel1="194.9288958333" vpos="112" h="0.0000000000" zoom="9.0032825384" rate="48000.0" snapto="off" selectionformat="hh:mm:ss + milliseconds" frequencyformat="Hz" bandwidthformat="octaves">

This part specifies the selected time region:

sel0="-7.0078541667" sel1="194.9288958333"

Note that “sel0” has a negative value. Due to a bug in Audacity 3.1.3, that negative value triggers the problem.
“sel1” must be greater or equal to “sel0”, and both must be zero or higher (must be positive).

In the fixed version you can see that I changed it to:

sel0="0.0" sel1="194.9288958333"

Ensure that you have a backup copy of the AUP file before you open it in NotePad++.

Thank you Steve. I will start going through my many previously generated projects (about 200+). Is there any hope this bug will be fixed anytime soon? This has really caused quite an impact for me now. It’s doable but will take time going through all those projects.

Really do appreciate you looking at this for me and coming up with the temp fix.

I believe this was fixed in the alpha of the next release, which will be 3.2.0. You can download and test the current nightly build yourself:

It is important to not do any production work on these builds, as these builds have not been production tested.

Thanks so much. Appreciate the info. Have a great day… :slight_smile: