Ver 2.0.5 crashes regularly; playback distorted

Ver 2.0.5-1ubuntu3.2 was installed on Ubuntu 14.04 about 2 years ago from the Ubuntu Software Center and worked well. There there was a recent lapse of about 6 months where I didn’t use it. Now, despite un-installing and re-installing to try to address these issues, I’m having no luck.

  1. About 7 out of 10 .aup files that I load, have badly distorted sound playback. It’s unidentifiable, although I know it to be music I recorded last Fall.
  2. It takes a good 40 seconds to load a 370 kB .aup file. I don’t remember it taking that long in the past. The display goes dark gray for a long period while it is loading.
  3. Infrequently a file will load and play correctly, but if I stop it, jump back to the beginning and re-start the play, it will often then be distorted and unusable.
  4. Much of the time, if I hit the square stop button, the display will turn dark grey and lock up. Can’t wait it out. Have to force a quit to close Audacity.
  5. Sometimes the program loads without the Unity menu bar visible at the top. There is then no way to “save” or edit or anything. I have the control panel, but no menus.

There’s obviously some corruption somewhere, but as previously mentioned, un-installing and re-installing doesn’t help.

I’m using on Ubuntu 14.04 desktop with 4 GB RAM, a 2009 circa ASUS mobo, GeForce 8400GS video card and Audigy ZS Sound card.

That’s going to be a pretty old version of Audacity. The current version is 2.1.3. What’s yours? (Look in “Help > About Audacity”).

To reset Audacity you need to delete the settings files which are in your home directory.
Open your file manager and enable “show hidden files” (probably an option in the “View” menu).
While Audacity is NOT running, find the folder “.audacity-data” in your home folder (note the dot at the start of the name). Delete that folder.
Restart Audacity and the folder will be recreated with Audacity reset to factory defaults.

Ensure that you have sufficient space on your hard drive. Working with audio requires a lot of free space.
The default location for Audacity’s temporary data is “/var/tmp” so ensure that there is plenty of free space there.

Don’t work with projects on external drives. Working with audio (or video) requires moving around a lot of data with high availability requirements, which is not handled well by external drives.

If you have Flash installed in your web browser, avoid running Audacity at the same time as Flash. (Note also that there are known security issues with Flash, so if you can manage without it then best to not have it installed).

Before starting major work in Audacity, reboot or log out and back in again so as to shut down applications that could potentially conflict (such as Flash).

Also shut down Nautilus file explorer if it is running. It can slow even a half decent system to unusability.

If you are choosing the pulse or default playback device in Audacity’s Device Toolbar, consider adjusting the pulse latency or using the hw device for the Audigy instead, which gives you direct access to that device. See which explains the pros and cons of this.

You can always use keyboard shortcuts if you cannot see the Audacity menu bar. CTRL + S to Save Project and so on. See


Thank you, Steve and Gale Andrews. It seems to be working now after I changed the output device from ‘default’ to an Audigy one. ‘sysdefault’ also seemed to work well, too. I think erasing the settings and starting fresh also helped. I’m going to save your posts to remind me some things to do if I run into trouble again. My version is 2.0.5. I did look into upgrading to the current version but couldn’t find a way to do it other than compiling from code. I’m sure that’s no big deal, but it appears above my pay grade and looks scary to me. I have managed to use Audacity on both my Windows desktop (XP and then 7) and an Ubuntu one (12.04 and 14.04) for about 6 years with few problems. But my aging brain forgets things and I do appreciate reminders from the outside. Knowing which help documentation to read is a big assist, too. Thanks again because I do love Audacity.

You can uninstall 2.0.5 and install a PPA package for 2.1.2 release (the version before the current one): This does not require compiling anything.


Thanks, Gale–will do.