Using the Metadata Editor

I’m running Audacity 2.0.0 under Ubuntu 12.04.
When using the Metadata editor, I habitually add, below the default tags, my own custom tag, with the name ‘Comment’. this is because most of the tag editors I have come across do not recognise ‘Comments’ as a tag, but they do recognise ‘Comment’.
Now, I’ve tried going to the Template group and clicking on Save, and I’m given the option of where, under what name to save this template, and I choose ~/.audacity-data and the default file name Tags.xml, but this file, on examination, seems to be merely 8 bytes long. If viewed in a text editor, it contains only one line, with the text ‘’. So I can’t see that the Template->Save function could be described as working. Perhaps this should be noted in the documentation.
Further to this, although the following is not an advertised feature, it is something most people would expect of a GUI.
I quite often take information into the values of the tags by cutting and pasting. But if I right-click on the value field of a tag entry, the Paste option does not work. If there is text already in the field, I can highlight it all by left-clicking in the field twice, but as soon as I right-click, the text is deselected.
I am no expert, but if you can tell me what language is used in the source code, and point me at the appropriate module, I could see if I can spot what’s going awry, and try to submit a suggested fix.
Regards, Phil Headford

Moved to the correct board.

Thanks for the report. It is on Bugzilla . Just add a space to the value of the “Comment” custom field.

Not tested on Mac but yes it’s a problem on Linux but not Windows.


src/Tags.cpp contains the Metadata GUI code but this is probably a generic wxGTK issue - the same thing happens in Labels Editor.