Using keyboard shortcut for nyquist

I use v 2.3.2 and had a very useful nyquist to cut 10 db that a user made available on the forum. It shows as “enabled” in Manage PlugIns but I have forgotten the keyboard shortcut to use it. I could reassociate the nyquist with another shortcut but I cannot find out how to put the shortcut and path together. Help please!!

Here’s how to create keyboard shortcuts in Audacity: Shortcuts Preferences - Audacity Manual

Sorry to be so late to see this Steve. My created file has this, a simple adjustment of Steve Daulton’s file:

;; cut-2-db.ny
;; by Steve Daulton Jan 2015
;; Released under terms of the GNU General Public License version 2:
;; .

(mult s (db-to-linear -2))

It is saved through notepad as cut-2-db.ny

When I try to assign Ctrl± and import the ny file, Audacity first prompts for an xml file. If I try and force the ny file Audacity responds: "Error: not well formed (invalid token) at line 1. Note this is Audacity 2.3.2. Thanks.

That’s very old code. For more recent versions of Audacity, replace the “s” with “track”:

(mult *track* (db-to-linear -2))

I appreciate your patience and the suggestion Steve. I changed the code as you suggested but that makes no difference to the error message. I am using Notepad and naming the extension .ny. I then tried to make the extension xml but with the same error. Also please recall I am using Audacity 2.3.2. Thanks for any help :slight_smile:

Don’t use NotePad. Use NotePad++ (it’s free).

Hi Steve. I was away for 2 weeks and sorry for the delay. I have installed Notepad + + and have saved this code as a .ny file
(mult track (db-to-linear -2))

but I still get and error message Syntex error and line 1

Sorry to continue this! :wink:

I am very very eager to get a chortcut to cut 2 db from some part of a track that I select. I se this software every day and it would ease my work enormously!! I am using Notepad + + as earlier suggested and have saved this code as a .ny file
(mult track (db-to-linear -2))

Frustratingly, Audacity 2.3.2 rejects the created file with the error message Syntex error at line 1. Please help!!! :slight_smile:

To create an installable Nyquist plugin, the file must include some special lines at the top of the file. These lines are referred to in the documentation as “headers”.

See this page for details: Nyquist Plug-in Headers - Audacity Wiki

Thanks Steve.Sorry to be boring … I have this as a Notepad++file now named as : cut-2db(final2).ny

;nyquist plug-in
;name Cut 2 db
;type process
mult track (db-to-linear -2)

But it’s still not working. (Error: not well-formed (invalid token) at line 1). My audacity is 2.3.2

The name needs to be in quotes.
;name Cut 2 db should be ;name "Cut 2 db".

A version number is required. Normally this should be version 4 (the latest type of Nyquist plug-in).
;version should be ;version 4.

mult track (db-to-linear -2) must be in parentheses, and track should be *track*.
All Nyquist commands are in parnetheses.
mult track (db-to-linear -2) should be (mult *track* (db-to-linear -2).

Also, ensure that ;nyquist plug-in is on the first line (no empty lines before it).

If it still doesn’t work after those changes, attach your .ny file to your reply so that I can check it.

cut-2db(final2).ny (95 Bytes)
Thanks a million Steve. My Audacity is 2.3.2. I am installing from Edit - Preferences - Keyboard

That plug-in works for me with Audacity 3.4.0.
I installed it using the “Nyquist Plugin Installer” (in the “Tools” menu in recent versions of Audacity).

Recent versions of Audacity require that Audacity is restarted after installing plug-ins.
Older versions of Audacity require that the effect is enabled (using the Plug-in Manager) after installing plug-ins.

In Audacity 2.3.2, if the effect does not show up in the Plug-in Manager, it is probably because you have installed the plug-in to the wrong place. I don’t recall if Audacity 2.3.2 had the Nyquist Plug-in Installer, but if it does, use it to install the plug-in (the Nyquist Plug-in Installer ensures that the plug-in is installed to the correct place.)

Steve… Thanks so very much for your patience. With v 3.3.2 it works. A million thanks Steve.