Using Chains to perform a simple task - not working

I’m using Audacity 2.1.1 on a Mac running OSx 10.11.6

I am trying to use the Chain function (for the first time) to batch process a group of 139 short audio wav files. Specifically, I want to apply some basic EQ processing to all 139 files. I have read the Audacity help file and some online help tutorials as well. Either I’m missing a step, (or a basic step in the process is missing from the explanation), or my laptop is in fact batch processing the files but putting them in a place I can’t find.

What I’ve done thus far:

  • I used “Edit Chains” (on the File drop-down menu) to create the EQ profile I want to apply. No problem. Everything appeared as I expected.
  • I then used “Apply Chains” (also on the File menu drop-down) to pull up the previously created profile. Here’s where the problem seems to start. I am never prompted for a location to place the new, (now hopefully processed) files. Audacity seems to open up all 139 files … BUT … they never appear to actually get run through an EQ process, or if they were, I can’t figure out where they are.

I have attached the chain I created. Maybe I’m missing a step???
The created Chain Instruction.png
Audacity Newbie.

As it says at the bottom of

The exported files will be saved in a folder named “cleaned” in the same folder that the original files came from

Does that solve the problem?

The current Audacity version is 2.1.3: Audacity ® | Download for Mac OS.


Thanks. I have done the following:

  1. With your input, I once again tried my original sequence/procedure already described in my previous post. Audacity did indeed create a “cleaned” folder. However, because the EQing I was doing was quite minimal, it was hard to tell if the source and the end file were actually different, especially when listening on small laptop speakers (which is what I’m doing the testing on at the moment). So…

  2. To address the problem (stated in item 1 above), I created a whole new chain - using extreme EQ settings - so there would be no doubt when comparing the source file with the end (equalized) file. Unfortunately, I got the same result. The program again created a “cleaned” folder. But the source file and the one that was exported to the “cleaned” folder were the same; they both were not equalized.

Seems strange to me but I must be missing something even though I tried to be very methodical when going through the procedure(s).



Have you upgraded to 2.1.3 yet?

Equalization does not work properly with Chains. If you use Equalization from the menus and change the curve, that current curve will be applied in the Chain, not the curve specified in the Chain. And in 2.1.1 any applied curve is saved flattened (that is, with no change to Equalization) due to a bug.

But if you use 2.1.3 and use Save / Manage Curves… in Equalization to save the required curve as a named curve, then choose that curve from the “Select Curve:” dropdown when setting the parameters for the Chain command, that should work OK.