Using Audacity with External Podcast Studio

I have installed a Behringer Podcast Studio consisting of an external mic, mixer, earphones and audio interface with hard wired USB connected to my MacBook Air. I have Audacity*, PodNova*, Juice* and Golden Ear* downloaded into the Apps file. When I go to Audacity to record I can’t get the external mic and earphones to work. Tabs: Core Audio (I am on a Mac), USB Audio CODEC for both the mic and recording, also 2 Sterio. Only way Audacity works for is using the computers built in mic and speakers.

Any ideas or suggestions very much valued as we are trying to start up a podcast.



You do know how to do the scratch tests, right? Scratch each microphone and announce where you are? Never, ever, blow into a microphone.

Restart Audacity. Audacity looks for audio devices when it starts. If you had Audacity already running when you plugged in the system, audacity will not see it. Also try Transport > Rescan.


Pull the USB connector out. Then reinstalled. Restarted Audacity. No more error but still not recording. Did the scratch test.

My mic is hooked up to a mixer and so are the earphones. All inputs and outputs go through the UCA audio interface’s USB connection to the computer.

Then reinstalled. Restarted Audacity.

I know it seems all encompassing, but reinstalling Audacity doesn’t do what you think. To “really” reinstall Audacity you have to reset it too.

While it’s gone, Go (top of desktop) > Go to Folder: ~/Library/Application Support
Don’t forget to put that little squiggly line at the beginning of the address. That’s a shortcut for your personal home folders.

Drag the “audacity” folder to the trash and then install Audacity. That’s where Audacity holds it’s preferences and settings to make updating easier. If you get a broken setting, it will stick around like a bad headcold no matter how many times you install.

So you connected the machine, started Audacity and there’s still no sound?

Close Audacity.

Apple (Upper Left) > System Settings > Sound > Input.

If everything is working, the bouncing ball sound meters should move when you scratch the microphone.

Do you get it that far? Audacity gets its sound from the computer, not the mixer.


Sorry, for taking so long to get back to your suggestions.

Did as you noted. Trashed the application support for Audacity and trashed Audacity. Emptied trash, restarted the computer and install Audacity from their download website. Audacity recognizes that I have Core Audio and USB Audio CODEC for input and output. When I go into System Preferences > Sounds >Input and scratch the mic I get nothing. I have even unplugged the other USB port where I have the printer connected. Have tried using that port also. No diffeernce.

I have a Logitech headset with mic and when I connect directly (no mixer or audio interface) I can record and it passes the scratch test. I got the PodcastStudio from Behringer and they also gave me dowloadable software: PodNova*, Juice*, Golden Ear*, Audacity*, and Podifier* (which does not work on this Mac). The Behringer people tell me that their hardware is compatible with MAC OSX.

It sure seems the issue is at the interface of the Behringer equipment and my MacBook Air and not in Audacity.

Any ideas?

Any ideas?

Yes, but I need to drop out for a while.

The Behringer stuff is perfectly compatible with Macs.