using arecord to record from USB Audio Capture device

I am using Lubuntu 14.04. i have an edirol UA3 Audio Capture device plugged into my USB port. It works fine. I go into audacity and I am able to record from Line in no problem. when i record using arecord it records from the internal mic on my Dell 1520 laptop. How can I use arecord to record from the line in on my USB device instead.

I tried using this and it works:

50 16 * * 4   /usr/bin/arecord -t wav -f cd -D hw:1,0 -d 87 /media/imac/BS3.wav
50 16 * * 4   /usr/bin/arecord -t wav -f cd -D hw:1,0 -d 87 /media/t60/BS3.wav

The only issue I have and for me it is a major one is that I can’t record at the same time when i have two or more recordings going on. Works fine from the Dell 1520 sound card. Am I doing something wrong? I would prefer to use the edirol because i have more options like not having to use the mic jack on my Dell 1520. I need to find a solution to thisso that i can record all of my radio shows.

Selecting the USB device from the alsamixer settings didn’t work either. Not sure if Pulseaudio would work.


Audacity will not work with two different shows at the same time and it doesn’t play well with others. It doesn’t understand sharing devices. Same reason it has trouble with Skype.


I’m not sure I understand the question, but it looks like you’re trying to aggregate your USB interface with internal audio.

Jack can do that. Have a look here:

Be forewarned, it doesn’t work with all devices and it can be quite buggy. I also don’t know if it works with Audacity.

Some audio devices have hardware mixing, others don’t.
If the device has hardware mixing, then multiple applications / instances can access the device at the same time.
If the device does not have hardware mixing, then only one application can access the device at a time - this is the reason why software mixing is built into advanced sound systems like PulseAudio.

It sounds to me like the sound card in the Dell laptop has hardware mixing built in, and the Edirol UA3 doesn’t.
PulseAudio should be able to handle this. Ensure that you have “PulseAudio Volume Control” (pavucontrol) installed - this allows you to configure devices and applications that are connected to Pulse.

To record from PulseAudio from the command line, use parecord. For help:

parecord -h