used to be able to record, cant do it anymore

I’ve been using audacity to record soundcard output for quite some time now. i used to have no problem doing this. i would just open audacity, play the sound i wanted to capture from youtube or windows media player or whatever, and it just worked. no fuss, no problems. today i attempted to do the same thing and it doesnt work. i have tried troubleshooting this problem myself for about an hour to no avail. the only difference between now and when i was able to record soundcard audio is that i recently installed a usb audio interface, a tascam us144mk2. it is not exactly an external sound card, but it is the device that sends audio output to my speakers. however as far as i can tell there is no option in win7 or audacity for using it as a default recording device, so i cant use it to send soundcard audio to audacity.

windows 7 home premium
audacity 2.0
realtek hd audio driver
tascam us144mk2 usb recording interface

i guess to sum it up i could say:
i could record youtube audio fine with audacity.
i installed a usb recording interface.
now i cant record youtube audio with audacity.

any suggestions would be greatly appreciated. thanks

It sounds like your USB interface is not “Set-up correctly” Is not “Compatiable”. Uninstall the interface and see if you can record again. if so then you have nerrowed it down to the card. Marty

unfortunately, installing this interface was no simple task. i was hoping to make it play nice with audacity and win7. i may try uninstalling it but unfortunately i dont have the time to undo what took me hours to accomplish and redo it at this time. i’ll probably just wind up sampling stuff on my old computer. its a shame though, i really liked being able to sample things on a whim with my new pc.

The Tascam us144mk2 is an “external sound card” (more precisely an “external audio interface”) and it probably does not support “Stereo Mix” recording (recording the output) on Windows.

You could use a pair of short cables to connect the Tascam “Line” outputs to the “Line” inputs and so record what is playing through the Tascam, but then you will probably lose sound from your speakers.

For other possible workarounds see here:

I am making an assumption that you did go into the Preferance and set up the Interface, Playback and Recording, You might have to just use the USB Audio CODEC for recording. Just checking Marty

I too was able to record, changed nothing and now Audacity can’t find the device. I did get it to start working and stopped the recording to start over and it quit again giving me the error message. The device is through a USB port and all of a sudden can’t find the device again. I tried another recording software and it doesn’t work either.
I’m using Windows 7 64 bit. No settings have been changed from previous recording sessions. The Audacity version is 2.0.0

Have a look in the Windows Sounds control panel to see if Windows has recognised the device and that it is enabled:

and now Audacity can’t find the device.

If Windows can’t find it, either, then the device has become unplugged or failed. It doesn’t have to fall out of the socket to become unplugged. USB connections are not click-positive connections and any dirt, humidity, or oils will kill the connection even if it’s plugged in all the way in. Unplug and plug multiple times or try a different USB connection.

Stay away from USB hubs. Those things do not play well with sound.


My mouse will work on the same USB. I’m not using a hub. It’s getting intermittent now. It started recording a song and I stopped it to back the tape to the beginning, then it flat lined again. It’s done this a couple of times. I tried another software and the device wouldn’t work on it either. I redownloaded lime and that never helped.

thanks for the suggestion. i’ve tried everything on that page to no avail. the line out to line in is an interesting idea, but as you say i would have to split the output again in order to send audio to the speakers. i suppose i’m asking on the wrong forum and i should probably go bother the guys at the tascam forum since this problem is most likely related to my new hardware and not the audacity program. thanks again :slight_smile: