USB recording level too high after upgrade to windows 7

I have reviewed posts, but not finding correct resolution
Upgraded to Audacity
When recording, audio host options are MME, Windows Direct Sound, and Windows Wasapi. Playback options are Realtek High Definition audio (works) and Microsoft Sound Mapper. Recording Options are: Microsoft Sound Mapper (works but sounds horrible), Microphone Realtek HD or Microphone USB Audio. I don’t have a microphone. Input jack from speakers, and USB cable from Numark turntable into computer are correctly installed, and never moved since upgrade to Windows 7.

Recording on microphone settings sounds like sonar from whales in the Atlantic. Can’t get “microphone” setting as input to change. No microphone installed.

I’ve reinstalled Realtek HD card

Input jack from speakers, and USB cable from Numark turntable into computer are correctly installed

What does “input from speakers” mean? Your soundcard has a mic input, and if you have a desktop computer it will have a line-input. Or, you can select a USB audio device and bypass your soundcard.

Your USB turntable probably has line-level RCA outputs and if you have line-in, you can optionally record those analog outputs with the right cable/adapter.

If you are trying to record from a USB input, you may need to install drivers. If Windows can’t “see” your turntable, Audacity can’t see it either. Once you get Windows to recognize it, you should be able to select it as your recording input for Audacity.

I don’t have a microphone.

Are you using a laptop with a built-in microphone?

The line in is from the speakers, and I am using the USB port to connect turntable to laptop. I have USB Audio Codecs installed as an option to use instead of the Realtek sound card, but in Audacity, the USB audio is not showing up as an option. Nothing changed from previous use, except upgrade to Windows 7. Maybe I’ll try to reinstall the USB Audio driver

I think I have the soundcard issues fixed. However, when recording, the input levels are maxed out to the right. I can’t adjust to lower the levels. When moving mouse to mixer tool bar, or on microphone icon, I can’t adjust. I get left/right arrow but no ability to adjust input levels. Any ideas?

Instead of saying in yesterday’s post that “recording was not working”, it is working. It’s just that I can’t adjust the input levels, which are currently pegged to max input, causing severe distortion during recording

If the Audacity Mixer Toolbar input slider is greyed out on maximum, then Audacity cannot control the input level.

Assuming you are still recording from the USB turntable and your Audacity recording device is set to the Numark USB Audio CODEC, do this. Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the Numark USB Audio CODEC, then choose “Properties”. Then click the “Levels” tab and adjust the input slider.

There may also be a knob under the turntable chassis to adjust the turntable output level.


how do you confirm “audacity recording device is set to Numark USB Audio Codec”? I don’t see that option. The clock icon is “sync lock tracks” when I right click. The only knob on underside is gain control. Before upgrade to Windows 7, I remember USB Audio Codecs as an option. Now it’s not there. Will try to reinstall, and get back with you (however, I did "re"download Audio Codecs but it still does not show up. By the way, your quick responses are commendable. Best IT/forum support I have ever experienced.

Try either plugging in the USB device first and then starting Audacity.

Or in Audacity use: Transport > Rescan Audio Devices


Audacity does not have the system clock that tells you the time of day.

The system clock is bottom right of your computer screen, assuming you have not reoriented the Windows Taskbar. Right-click over the speaker icon that is somewhere near the system clock. Or open the Windows Control Panel and find “Sound”.

That is good. The level of output coming from the turntable affects the recording level, even if you cannot change the recording level.

A Numark USB turntable just uses the Windows USB Audio Class drivers. The turntable device may show as “Numark” but there are no codecs to download.

Don’t download and install arbitrary audio codecs unless you know what you are doing.


If I adjust the input volume to 0.1, all the way to the left but just above zero, recording is now at proper levels. When set to just above zero, I am hitting -6db as suggested in Audacity manuals. It was not like this before Windows 7 upgrade, but I guess this will close out my problem. I appreciate all your help

USB audio inputs are typically “hotter” on Vista and later than on previous Windows.

You can try configuring the USB input level using “Speech Recognition” but I am a little sceptical that helps.